Redshift Tool invalid node type name

   4312   4   0
User Avatar
Member
1 posts
Joined: 11月 2020
Offline
Hey guys,
I have a problem. I just downloaded Redshift but it does not seem to be working properly. Every time I try to set a redshift node I get this kind of error :


The attempted operation failed. Invalid node type name.

Traceback (most recent call last):
File "Redshift", line 1, in <module>
File "/Applications/Houdini/Houdini18.5.408/Frameworks/Houdini.framework/Versions/18.5/Resources/houdini/python2.7libs/roptoolutils.py", line 10, in createRenderNode
rop = hou.node('/out').createNode(rop_type, exact_type_name=exact_type_name)
File "/Applications/Houdini/Houdini18.5.408/Frameworks/Houdini.framework/Versions/18.5/Resources/houdini/python2.7libs/houpythonportion/ui.py", line 1010, in decorator
return func(*args, **kwargs)
File "/Applications/Houdini/Houdini18.5.408/Frameworks/Houdini.framework/Versions/18.5/Resources/houdini/python2.7libs/hou.py", line 13126, in createNode
return _hou.Node_createNode(self, node_type_name, node_name, run_init_scripts, load_contents, exact_type_name, force_valid_node_name)
OperationFailed: The attempted operation failed.
Invalid node type name



I don't know what that means and nobody on the internet seems to have an answer to the problem. I hope someone can help or have some advice on how I can fix it.

Any advice is greatly appreciated.
Thanks for the read!
User Avatar
Member
1 posts
Joined: 12月 2020
Offline
I am having the same problem, and I can't find solution in the internet!

Anyone any idea how to solve this? I'm using a Mac

Thanks!
User Avatar
Member
16 posts
Joined: 7月 2020
Online
Unfortunate that nobody has figured this out. I have an open support ticket with Redshift about it but they're taking a while to respond.
User Avatar
Member
16 posts
Joined: 7月 2020
Online
Ok, I figured this out. My houdini.env was wrong. Make sure you fully follow the instructions here including adding the HOUDINI_PATH and PATH (which I was missing)
User Avatar
Member
1 posts
Joined: 4月 2020
Offline
@maxpleaner (Ok, I figured this out. My houdini.env was wrong. Make sure you fully follow the instructions here including adding the HOUDINI_PATH and PATH (which I was missing)

The correct response to this is to ensure that you install the correct Redshift plugin version that matches the version of Houdini you are using. Ie; Houdini Version 18.5.499 should match Redshift plugin Version 18.5.499 - This is the only way that setting up the .env file will enable the nodes to match correctly as denoted in this excerpt (P/s - the same excerpt I had posted earlier)

Windows
The houdini.env file is located at C:\Users\<username>\Documents\houdiniX.X\houdini.env (for example: C:\Users\<username>\Documents\houdini19.0\houdini.env)

Add the lines:

HOUDINI_DSO_ERROR = 2
PATH = "C:/ProgramData/Redshift/bin;$PATH"
HOUDINI_PATH = "C:/ProgramData/Redshift/Plugins/Houdini/${HOUDINI_VERSION};&"

Excerpt source here: https://vfxrendering.com/how-to-install-redshift-for-houdini/ [vfxrendering.com]
Edited by berekinuthia - 2023年9月24日 13:54:50
  • Quick Links