Tristan Reimus

Pumpkinking4

About Me

Expertise
Not Specified
Location
Not Specified
Website

Connect

Recent Forum Posts

Vertex Animation Textures ROP 2.1 Released May 21, 2021, 3:36 a.m.

MaiAo
Mary537
Hi,
I need to import a RigidBody simulation in Unreal exported by VAT, but after I'm defining the material values and textures the asset has holes. How can I solve?
Another question: How can I create LODs for my simulation with vertex animation?
I used Houdini 18.5.499, VAT 2.1 and Unreal 4.25 and 4.26

Hi, what you captured in the screenshot is a known bug with VAT-Rigid export mode. The fix is very very soon (April 27th Edit: the release data was pushed back; expected to come early May 2021). Stay tuned!

To your second question, you will unfortunately have to export separate meshes and textures for LOD purposes and control LOD using BP or code. Because the textures and exported vertices of the mesh are intrinsically mapped one-to-one, you cannot LOD the mesh in the traditional way and still be able to use the same vertex animation textures.

Heya, any update on that offset fix? Eagerly awaiting it here. Thank you

Vertex Animation Textures ROP 2.1 Released Nov. 11, 2020, 5:32 a.m.

Heya, I'm trying to put the VAT export node inside of my HDA but it doesn't want to cook anymore and I can't figure out why. I put a VAT node in a ropnet, then linked all the params by dragging the node into type properties of the HDA. I assume it has to do with the _component param on the HDA, the python script on there doesn't seem to work? (left of attached img)

When I press render on the VAT it'll look like it's processing like normal but spits out this error on the ‘render_mesh_fbx’:
Error 
FbxExporter::Initialize() failed. Error returned: File not created
Error
Unable to evaluate expression (
Traceback (most recent call last):
File "<stdin>", line 4, in expression
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.351/houdini/python2.7libs\toolutils.py", line 1779, in createModuleFromSection
node_type.definition().sections()[section_name].contents())
KeyError: ('vat_utils.py',)
(/obj/boat/NT_RBDsimFromAnim/_project)).

Been stuck on this for a while now, if anyone has some ideas where I can look I'd be grateful!