Guided Ocean Layer Help?

   3021   5   1
User Avatar
Member
2 posts
Joined: March 2017
Offline
Hey everyone!

I've been messing around with the new guided ocean layer approach in Houdini 16, but came to realize my simulation goes haywire when I lower the particle separation. Everything seems to be respected at a particle count of 740,000, but when I simulate 3,000,000 points the velocities go crazy and I get patches where particles disappear.

I attached both flip-books to show what I'm talking about.
Both files have the same parameters just a different particle separation.
Edited by goertzfx - March 5, 2017 12:18:21

Attachments:
hi_res_sim.mp4 (2.9 MB)
lo_res_sim.mp4 (2.9 MB)

User Avatar
Member
2 posts
Joined: March 2017
Offline
Any help or idea why this is happening?
User Avatar
Member
7 posts
Joined: May 2015
Offline
The same thing happens with mine sim.
After couple of frames RAM goes through the roof and exactly this happens…
User Avatar
Staff
684 posts
Joined: July 2006
Offline
Would one of you mind submitting a bug along with your .hip files? It looks like the particles layer is not thick enough, and you're seeing the FLIP sim “fall through” the guided layer, but we'd need to see the .hip file to be sure.

Thanks
User Avatar
Member
7 posts
Joined: May 2015
Offline
Hi… Thank you for reply…

Here is the .HIP file.
I had to replace the geometry (reason why there's no proper animation and camera).

From what I can see thickness should be calculated accordingly to the separation… or am I wrong?


Kind regards
Chris

Attachments:
guided_sim_send.hip (3.0 MB)

User Avatar
Staff
684 posts
Joined: July 2006
Offline
Thank you for the report and the file. This is indeed a bug. The problem is the expression that the Guided Ocean Layer shelf tool puts in the Grid Scale parameter of the OceanSource SOP. Since we're usually using the Max Resolution parameter to limit the amount of high-frequency waves we're sending into the OceanSource, it doesn't make sense to generate a really high resolution volume to represent just those low-frequency waves. However, the output guiding surface SDF does have to be high enough resolution to maintain the Guiding Layer Thickness, which gets smaller as the Particle Separation decreases, and that was not being taken into account in the Grid Scale expression.

Short-term workaround, clear out that expression and set the Grid Scale to 6 (or even 8 in your example, I believe). You can put a Convert Volume SOP on the output of the OUT_GUIDING_SURFACE SOP to ensure there are no holes in the surface with the smaller grid scale.

We'll be updating the Guiding Layer shelf tool to correct this. Thank you again for the report.
  • Quick Links