polybevel warning - "Skipping inconsistently wound manifold edge"

   1426   6   2
User Avatar
Member
54 posts
Joined: Feb. 2017
Offline
Been hunting for answers on this tonight. Attached is the .HIPLC for anyone to take a peak at. Here is a verbal explanation-

Nurbs Sphere > Carve Extract > Resample segment count > poly Extrude twice but reverse the distance > merge > fuse > polybevel the seam that was fused.

Doesn't work and yields the warning - “Skipping inconsistently wound manifold edge 37-38.” multiple times.

I'd like to think myself a competent modeler outside of Houdini (Maya/3ds). I can't figure out why this isn't working in Houdini. Please give me a hand.

Thank you!

EDIT: Using Houdini 16 on a windows 10 machine.
Edited by 9krausec - May 10, 2017 21:39:48

Attachments:
pBevelIssue.hiplc (82.0 KB)

User Avatar
Member
4113 posts
Joined: July 2007
Offline
put Reverse SOP right after your polyextrude2 as extruding in negative direction causes polys to face opposite direction, you can visualize it by turning on primitive normals in the viewport
Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
54 posts
Joined: Feb. 2017
Offline
Wow. I feel like a dummy. Same thing in Maya. When I get out of the office (don't use Houdini at work, yet), I'm going to look into display options to show back facing faces in black so I can get a visual queue when something is wrong.

Thanks again!
User Avatar
Member
2612 posts
Joined: Sept. 2011
Offline
9krausec
Wow. I feel like a dummy. Same thing in Maya. When I get out of the office (don't use Houdini at work, yet), I'm going to look into display options to show back facing faces in black so I can get a visual queue when something is wrong.

Thanks again!

There's no way to mark back faces that way, because what's a backface to one point of view is not to another. That's why it makes more sense to just display the prim normal and be able to make an informed judgement based on the big picture. There is an option to hide backfaces, by backfacing from the camera.
User Avatar
Member
9 posts
Joined: Feb. 2018
Offline
Hi, I'm having a similar issue but with a bit different setup. Reverse SOP doesn't help. Could you please advise?

Attachments:
polyBevelIssue.hipnc (75.2 KB)

User Avatar
Staff
1731 posts
Joined: March 2012
Offline
illiastatkevych
Hi, I'm having a similar issue but with a bit different setup. Reverse SOP doesn't help. Could you please advise?
It looks like the polygons in group2 are wound the wrong way. PolyBridge has the “Delete Source Primitives” and “Delete Destination Primitives” options on by default, because they will usually be like caps filling the hole in a larger surface that's also being filled by the bridge, so they will have their normals pointing inside the bridge, instead of outside.

If you use a Reverse SOP on the branch dealing with group2, then on PolyBridge, have the Source Reverse Winding checked, and the Destination Reverse Winding unchecked, that seems to get things to work. Alternatively, you could skip a whole lot and after the first PolyExtrude, just rotate the model 180 degrees around y (or use Reverse), then use another PolyExtrude, turning on Output Back.
User Avatar
Member
6 posts
Joined: Oct. 2014
Offline
Hi all, I resolve this problem I using Clean node uncheck Remove Unused Points, uncheck Remove NANs and check Manifold Only Topology, now bevel is correct.
  • Quick Links