Heightfield Erode Fails

   4805   13   4
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
Hi everyone,

The heightfield erode node immediately crashes when I try to view it, giving me the error:

OpenCL Exception: clCreateProgramWithSource (-34)

I tried typing HOUDINI_OCL_DEVICETYPE=“GPU” and HOUDINI_OCL_VENDOR=“NVIDIA Corporation” into the houdini.env file as suggested by a previous post but this did not work.

I'm on a Razer Blade laptop with:
Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
NVIDIA GeForce GTX 970M
16GB RAM

Any help would be greatly appreciated!
User Avatar
Staff
4513 posts
Joined: July 2005
Offline
Does HOUDINI_OCL_DEVICETYPE=“CPU” work?
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
Error still happening with either:

HOUDINI_OCL_DEVICETYPE=“GPU”
HOUDINI_OCL_VENDOR=“NVIDIA Corporation”

or

HOUDINI_OCL_DEVICETYPE=“CPU”
HOUDINI_OCL_VENDOR=“Intel(R) Corporation”

:

Unable to load HFS OpenCL platform.
OpenCL Exception: @*Í8¸ (-32)
OpenCL Exception: clCreateProgramWithSource (-34)
OpenCL Exception: clCreateProgramWithSource (-34)
OpenCL Exception: clCreateProgramWithSource (-34)
OpenCL Exception: clCreateProgramWithSource (-34)
OpenCL Exception: clCreateProgramWithSource (-34)
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
Okay I solved the OpenCL issue by putting this in houdini.env:

HOUDINI_OCL_VENDOR=“NVIDIA Corporation”
HOUDINI_OCL_DEVICENUMBER=0

However the Erode node still does not work. I'm attaching screenshots of the error.

Edited by canonball900 - Nov. 15, 2017 23:37:46

Attachments:
1.PNG (1.5 MB)
2.PNG (1.6 MB)

User Avatar
Member
6284 posts
Joined: July 2005
Offline
Does your laptop have Intel + Nvidia? I am having the same issue at home on my laptop too, Windows 10.

I've tried all the combos of the ENV vars to no avail.

I have had this work (setting the env vars) to use Nvidia for OCL in the past, I wonder if something changed in Houdini or on my end (since Windows updates crap without warning )

Cheers,

Peter B
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
I got Houdini to use Nvidia for OpenCL using the above commands in the env - I no longer get an OpenCL error. But you think the problem (see photos) is still an OpenCL issue?
User Avatar
Member
221 posts
Joined: July 2013
Offline
My laptop has Intel + nVidia, and by default, Houdini will select the device configured in nVidia control panel.

Using houdini.env you can configure which device is used for OpenCL, bypassing the nVidia control panel setting.
Houdini Indie
Redshift 3D
User Avatar
Member
6284 posts
Joined: July 2005
Offline
Yeah I have my Nvidia setting to always use Nvidia, never the garbage Intel GPU. However, without setting env vars, the OpenCL uses Intel but the OGL uses Nvidia.

I pine for the old days of no Intel GPU at all on a laptop

Cheers,

Peter B
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
Okay so I've literally tried everything at this point. I get Houdini to use my NVIDIA GTX 970M for OpenCL just fine but it is still giving me the error: Unable to load HFS OpenCL platform.

I have tried older NVIDIA drivers, AMD OpenCL driver, Intel OpenCL Driver, multiple houdini environment variable configurations, changing the NVIDIA settings to use GPU… nothing works. Apparently re-installing Windows worked for someone but I don't have time to do that right now. Anyone have a brilliant solution?

Here's what it shows in the Houdini Command Line:

Unable to load HFS OpenCL platform.
OpenCL Platform NVIDIA CUDA
Platform Vendor NVIDIA Corporation
Platform Version OpenCL 1.2 CUDA 9.1.92
OpenCL Device GeForce GTX 970M
OpenCL Type GPU
Device Version OpenCL 1.2 CUDA
Frequency 1038 MHz
Compute Units 10
Device Address Bits 64
Global Memory 6144 MB
Max Allocation 1536 MB
Global Cache 160 KB
Max Constant Args 9
Max Constant Size 64 KB
Local Mem Size 48 KB
2D Image Support 16384x16384
3D Image Support 4096x4096x4096
Edited by canonball900 - Nov. 17, 2017 01:32:19
User Avatar
Member
6284 posts
Joined: July 2005
Offline
Try this, it helped my Houdini become a lot more stable on my hybrid Intel/Nvidia laptop…

https://support.allegorithmic.com/documentation/display/SPDOC/GPU+drivers+crash+with+long+computations [support.allegorithmic.com]
User Avatar
Member
6284 posts
Joined: July 2005
Offline
BTW, I always get the “Unable to Load HFS OpenCL Platform” but the GPU works anyway once I set that Allegorithmic tip.
User Avatar
Member
13 posts
Joined: Dec. 2016
Offline
Looks like it works in Houdini 16.5! Thanks for all the help guys
Edited by canonball900 - Nov. 18, 2017 23:37:21
User Avatar
Member
3 posts
Joined: May 2016
Offline
I had this problem as well, and installing 16.5 or setting things in houdini.env as suggested above didn't help.

A workaround for me was to install the Intel OpenCL runtime for my Linux system. Now Houdini uses OpenCL on my CPU, which is much better than nothing (though my GPU supports OpenCL just fine in theory).
User Avatar
Member
1 posts
Joined: Dec. 2018
Offline
I tried several times in my laptop but same result… I finally found an OpenCL Parameter in the “Miscellaneous” menu. I changed my graphic device, restart Houdini,
Image Not Found

and now it's gone and I can use the erode tool by example. Hope it will help you.
  • Quick Links