Layers not showing up when importing digital asset for terrain

   118   2   1
User Avatar
Member
3 posts
Joined: Nov. 2017
Offline
Hello, I was having quite a bit of difficulty setting up a landscape material from my Houdini Digital asset that I imported into UE4. I am using Houdini Indie 16.5.311, UE 4.18.1 and my operating system is windows 10. I cannot figure out why the layers are not showing up when I apply the material. My understanding is that the digital asset automatically creates them as the layers and you can just give them the proper name in the material. To test this I made a very simple demonstration of how I think this works based on my research. I added the time shift node so that my frame being used in the asset should hold values other than 0. I included a heightfield quick shade to show that the layers do exist in houdini. Any ideas on what might be wrong?

Attachments:
Screenshot (382).png (1.7 MB)
Screenshot (378).png (415.4 KB)

User Avatar
Member
8 posts
Joined: April 2017
Offline
Got a screenshot of the landscape in UE with the ‘Paint’ tool selected, you should have your ‘water’, ‘debris’, … layers in there.
User Avatar
Staff
119 posts
Joined: Sept. 2016
Offline
Hi,

Your setup seems fine, the landscape layer should be imported with the hda.

One thing that can remove them, is if the mask/layers are “empty” (all to the same value), which in your case might happen if you're at the first frame.

Using the timeshift node, I suggest you set its frame value to a fixed one instead of $F, as HDA will always have $F set to 1 (remove the keyframe by ctrl-clicking on the frame param, and set a number there).

You can also promote the frame parameter to the asset, and control it in UE4.

In UE4, as daveREspawn suggested, the layers should show in the landscape tab with the paint tool selected.
You can also use the Layer Debug visualizer in the viewport to see them.
  • Quick Links