Plugin failed to load in 4.20

   900   9   0
User Avatar
Member
1 posts
Joined: April 2018
Offline
I installed UE 4.20 then houdini-16.5.539-win64-vc14 to get the 4.20 compatible plugin. Weirdly it wasn't copied over during install so I did it manually. On startup the following message shows up:

Plugin ‘HoudiniEngine’ failed to load because module ‘HoudiniEngineRuntime’ could not be found.
User Avatar
Staff
241 posts
Joined: Sept. 2016
Offline
Hi Zoltan,

Some changes in Unreal 4.20 did cause some issues with the installed version of the plug-in.
More precisely, the pre-built runtime component is not generated anymore by the Unreal build system.

Currently, the only way to use the 4.20 plug-in is to build it from the source.
(either the sources that ship with Houdini, or the source on Github)

I'll post an update here once that issue is solved.
User Avatar
Member
4 posts
Joined: Feb. 2017
Offline
I am struggling to get 4.20 working as well….

Confused about needing a custom engine build - is it possible just to compile the plugin as part of a c++ ue project using the launcher's rocket engine?

Typically a plugin can be used at engine or project level?

But when compiling Houdini plugin from source - it seems there are hard coded engine paths?

Thanks for any feedback
User Avatar
Member
4 posts
Joined: Nov. 2016
Offline
+1, hope to see a binary version of the plugin ship in the near future! Thanks!
User Avatar
Staff
241 posts
Joined: Sept. 2016
Offline
Hi,

Binaries for the UE4.20.1 plug-in were added to 16.5.553 (windows).
Mac binaries should come shortly after.
User Avatar
Member
4 posts
Joined: Feb. 2017
Offline
Thank you! Works great in 4.20!
User Avatar
Member
10 posts
Joined: Nov. 2017
Offline
I just installed Houdini 16.5.558 and 16.5.559 on Windows 10. Neither of them seemed to get the plugin working in Unreal 4.20.1? Suggestions?
User Avatar
Staff
241 posts
Joined: Sept. 2016
Offline
Hi,

The UE4 plugin in those version should work fine.
However, there seem to be an issue with autostarting a pipe Houdini Engine server in recent version.

Try changing your session type to TCP sockets in project settings, and restart Unreal.

Another solution would be to connect to an existing HARS process or Houdini Engine Debugger session.
User Avatar
Member
2 posts
Joined: April 2017
Offline
HI,any update on ue 4.20.2? Thanks
User Avatar
Staff
241 posts
Joined: Sept. 2016
Offline
Hi,

4.20.2 should be supported in the latest daily builds.
  • Quick Links