Proper conversion of vertex attribute UVs

   237   5   1
User Avatar
Member
14 posts
Joined: Feb. 2017
Offline
I'm running into the problem that my UVs (in the form of vertex attributes) are not being brought over properly into max. What I get is disconnected polygons in the UV channel, which I have to re-weld using a small radius. I'm basically running into the same problem as is described in the thread here: https://www.sidefx.com/forum/topic/55014/ [www.sidefx.com]. The vertex split method works but it's obviously not what I want and just shifts the problem into a different area.

I did read in a different thread that fbx export corrects for that, so it would be great if this could be done with the the houdini engine for max too .
User Avatar
Staff
169 posts
Joined: Aug. 2017
Offline
Thank you for bringing this up! I will log a bug/RFE for maintaining the welds on the UVs.

- Brandon
Edited by BrandonA - Oct. 15, 2018 10:24:59
User Avatar
Member
14 posts
Joined: Feb. 2017
Offline
Great! Thanks
User Avatar
Member
137 posts
Joined: Feb. 2017
Offline
hope this helps but I found that the only one that works is the uvproject, set the Group Type to Points…works perfectly.

So I tested a uvpelt, then added a uvedit after so I can set the Group Type to Points…didn't work…tried other ‘ways’ to set the Group Type to Points…none worked.

So seems like there is some dark magic in the uvproject>Group Type Points that makes it work…

ahhhh….checked the spreadsheet, only the uvproject with Group Type = Points has uv set, all other uv operators…..uv's get all wiped out….
Edited by vusta - Nov. 12, 2018 01:01:42
User Avatar
Staff
169 posts
Joined: Aug. 2017
Offline
vusta
hope this helps but I found that the only one that works is the uvproject, set the Group Type to Points…works perfectly.

So I tested a uvpelt, then added a uvedit after so I can set the Group Type to Points…didn't work…tried other ‘ways’ to set the Group Type to Points…none worked.

So seems like there is some dark magic in the uvproject>Group Type Points that makes it work…

ahhhh….checked the spreadsheet, only the uvproject with Group Type = Points has uv set, all other uv operators…..uv's get all wiped out….

When you say the UVs are getting wiped out, do you mean that the UVs get wiped out in 3ds Max? If so, which build are you using? Recent daily builds of the plugin should not be experiencing this problem.
User Avatar
Member
137 posts
Joined: Feb. 2017
Offline
BrandonA
vusta
hope this helps but I found that the only one that works is the uvproject, set the Group Type to Points…works perfectly.

So I tested a uvpelt, then added a uvedit after so I can set the Group Type to Points…didn't work…tried other ‘ways’ to set the Group Type to Points…none worked.

So seems like there is some dark magic in the uvproject>Group Type Points that makes it work…

ahhhh….checked the spreadsheet, only the uvproject with Group Type = Points has uv set, all other uv operators…..uv's get all wiped out….

When you say the UVs are getting wiped out, do you mean that the UVs get wiped out in 3ds Max? If so, which build are you using? Recent daily builds of the plugin should not be experiencing this problem.
in H spreadsheet itself. With the uvproject (Group Type Point), you see values for each point…in the 3 uv columns. For other ops…the 3 uv columns are no longer there.
  • Quick Links