HARS.exe not working

   993   1   1
User Avatar
3 posts
Joined: May 2015
Hey all,

After searching and searching I'm still unable to get Houdini Engine for Maya 2018 to work.

Everytime I go to load the plugin in Maya it waits a second then pops up saying that HARS.exe has stopped working.
Also, in the script editor there is this message:

// Automatically starting Houdini Engine server using named pipe. //
// Automatically started Houdini Engine server using named pipe at “CUsers/FX/AppData/Local/Temp\houdini_temp\hapi33608”. //
// Connected to Houdini Engine server using named pipe at “CUsers/FX/AppData/Local/Temp\houdini_temp\hapi33608”. //
// Houdini Engine failed to initialize. //
// Result: houdiniEngine //

I am on Houdini 17 using Maya 2018 on Windows 7.

If anyone has any tips on how to get Houdini Engine to work in Maya 2018 I would greatly appreciate it as I have tried uninstalling Maya and Houdini several times now and am starting to pull my hair out.

User Avatar
146 posts
Joined: Oct. 2017
What platform are you working on? There are problems with autostart on some older versions of Linux (e.g. Ubuntu 16.04 and older seems to have issues, 18.04 is fine) Windows and Mac seem OK (so far, anyway)

Until we get this figured out, you'll need to explicitly start HARS, and set the houdini preferences to not autostart.

To start HARS with a named pipe named hapi
HARS -n hapi

set your optionVars to use the explicitly named pipe before loading the plugin - If you've tried loading 17.0 and had the Houdini Shelf installed, you can click on the NpS item, or you can set the following.

optionVar -iv “houdiniEngineSessionType” 2;
optionVar -iv “houdiniEngineSessionPipeCustom” 1;
optionVar -sv “houdiniEngineThriftPipe” “hapi”;
  • Quick Links