Bad Parameter reference error

   6444   10   0
User Avatar
Member
4 posts
Joined: April 2006
Offline
Hi I am new to houdini and have been following a rohan delvi tutorial. I am trying to render my scene out in mantra but I keep getting this error

warning: Bad parameter reference: “enableDispMap” in parameter /ma/uniformvolume/vm_displacebound/floatdef.

I have no idea how to follow this path to the correct node. Can someone help me decipher this?
User Avatar
Member
689 posts
Joined: Dec. 2006
Offline
I think that should read /mat/uniformvolume/vm_displacebound/floatdef.

This means it's in /mat, (your material network) and it's pointing to the uniformvolume shader. If you mouse over each paramater, you will see it's real name, and you will eventually come to “vm_displacementbound”, (which is the displacement bound… tells mantra how far it can expect to displace the volume). There is something wrong with this expression, it looks like it is pointing to a parm that does not exist… just delete it for now.

I don't know though that this would cause your render to fail, these are usually benign errors.
Sean Lewkiw
CG Supervisor
Machine FX - Cinesite MTL
User Avatar
Member
43 posts
Joined: May 2013
Offline
I am getting this error as well, rendering a flip simulation. The uniformvolume shader is right out of the box. I didn't touch it. My scene will render with the errors using the film cannister button in the lower left corner of the Scene View, but rendering by pressing “render” on the mantra node fails. The weird thing is that it renders two frames, then fails on frame 3. After I did a “delete channel” on the displacement bound the problem went away. I'm on Centos 7, Houdini 17.0.352.
Edited by johnLIC - May 23, 2019 10:52:50
User Avatar
Member
43 posts
Joined: May 2013
Offline
I think this problem might be due to running out of disk space on my root partition.
User Avatar
Member
1 posts
Joined: Oct. 2015
Offline
I don't think it's the disk space. I was having the same issue with my flip sim not rendering and giving this same error on a fresh reset computer but when I un-promoted the vm_displacebound it seemed to fix immediately. Posting this for anyone else that may run into the error later like I did.
User Avatar
Member
73 posts
Joined: March 2020
Offline
Hmm the parameter references are indeed wrong. They are all missing “../” as they should refer to the enclosing material builder node. If you replace the expression with the following, the error goes away.

max(abs(ch("../enableDispMap") * ch("../dispScale")), abs(ch("../enableNoise") * ch("../dispScale") * ch("../noiseAmp")))
User Avatar
Member
1 posts
Joined: Jan. 2020
Offline
Ive copied and paste the expression, it still displays the same error. Any idea why?
User Avatar
Member
1 posts
Joined: July 2016
Offline
Aha,I find why. This is bug for Uniform Volume node.

Default , This channel should be disable if you don't check Enable Displacement Map Channel.
But original node they have a mistake.
What ever you use or not this channel, Displacement Bound always want a value.


So easy to fix it.

1.right click in this material node.
2.find Displacement Bound(Vm_displacebound)
3.Use {enableDispMap==0 enableNoise==0} replace old expression
4.Done.

Attachments:
uniformvolume node_parm bug.png.png (97.7 KB)

User Avatar
Member
1 posts
Joined: Jan. 2022
Offline
I'm a new Houdini user & I'm having the same issue. Tried everything mentioned here, but didn't work. This looks like a general problem, and I'm surprised that this page is the only one in the entire web that is trying to address it. Houdini is a complicated software, so if as a new user you get an error like this, you have no idea what to do. Any other ideas?
User Avatar
Member
1 posts
Joined: May 2022
Offline
just change the parameter type from float to integer
User Avatar
Member
5955 posts
Joined: Sept. 2011
Offline
boss.tleuli
just change the parameter type from float to integer

just ignore it, it doesn't matter.
  • Quick Links