Houdini Engine for Unity Missing

   200   4   1
User Avatar
Member
39 posts
Joined: Dec. 2013
Offline
In case anyone else has this issue:

Not sure if this is on SideFX or Unity3D. I have Houdini Engine for Unity 17.5.360 Engine Version 3.2.43 installed to Unity 2019.2.8f1. I have HEngine installed for a long time. Recently, I installed through the Window->Package Manager three tools. Polybrush, ProBuilder, and Rider Editor. After this was installed, HEngine was working fine. I restarted Unity, and HoudiniEngine in the toolbar disappears, and I can't load any HDAs into the Hierarchy.

I tried installing the Houdini Engine package again, and a window appeared saying it was in my project.

Steps I took to fix this was remove ProBuilder first. Restarted Unity, and still nothing. I then removed Polybrush and Rider Editor, restarted Unity, and Houdini Engine is back in its working glory.

Is this a bug for SideFX or Unity3D?

Glen
User Avatar
Staff
472 posts
Joined: May 2017
Offline
Are there errors on the console? Usually the menu disappears if there are errors with the plugin source code.
User Avatar
Member
39 posts
Joined: Dec. 2013
Offline
Hi Seelan,
I have no errors in my console. I tried with another package, through the Package Manager. This time it was Cinemachine, and Houdini Engine disappears at the top of the toolbar. It was replaced with Cinemachine. On my HDA, it has a Missing Script warning.


Glen

Attachments:
2019-10-21_21h54_13.png (6.6 KB)

User Avatar
Staff
472 posts
Joined: May 2017
Offline
If you have no errors, then my other guess would be that the scripts have lost references. In which case, to fix it, you might simply need to reinstall the Houdini Engine plugin. See upgrade steps here: https://www.sidefx.com/docs/unity/_getting_started.html#GettingStarted_Update [www.sidefx.com]
User Avatar
Member
39 posts
Joined: Dec. 2013
Offline
Thanks for assistance. We tried re-installing Houdini Engine and received a warning that it was already installed. We figured out a way to have Houdini Engine with the installed Packages. We cleaned out our Houdini and Cinemachine package from our project. Restarted, Computer. We installed Houdini Engine, restarted Unity, installed Cinemachine package and restarted all of our machines. Houdini Engine and Cinemachine are now working together. Not sure why it is happening, just happy it is.
Glen
  • Quick Links