Possible To Use RBD to FBX on a SOP Simulation?

   315   3   1
User Avatar
Member
5 posts
Joined: Nov. 2019
Offline
I am using a simulation in a SOP with the RBD Bullet Solver in order to use the guided simulation feature in 18. I am running into an issue where I cannot export the sim to an FBX that I can read in Unreal since all the examples I can find online seem to require an Auto DOP network, and those networks don't seem to support the solver that can take geometry as a guide? I am quite new to Houdini so am still finding my way around, and this in particular has had me stumped for quite a while. Definitely appreciate any help that anyone can offer! Every time I try to export I either get nothing, or the geometry with no animation or bone hierarchy present.

Stephen
User Avatar
Member
5 posts
Joined: Nov. 2019
Offline
I was able to solve this using someone else's bullet solver node (which was marked unlocked, but I don't know what they changed) from a hip that was posted on the website. It is still unclear to me why it was NOT working in the first place as everything else seems to have remained the same. Will update here if I discover what the difference was.
User Avatar
Member
809 posts
Joined: May 2006
Offline
If you're brave you can dive into the guts of the rbd sop solver and step through the network, find the node that's breaking stuff. I did this a few weeks ago, found it was a node expecting a certain naming stricture,that in turn broke the rbd to fbx exporter, but I cant remember the details unfortunately.

If you're new to houdini that might be a big ask though! If you can make a simple repro and have it fail consistently you should post it to support@sidefx.com, they normally fix niggly things like this pretty quickly (especially if its an issue on the labs side). I can't remember if I posted my bug to sidefx, which is lame on my part… :/


-matt
http://www.tokeru.com/cgwiki [www.tokeru.com]
https://animallogicacademy.uts.edu.au/ [animallogicacademy.uts.edu.au]
User Avatar
Member
8 posts
Joined: Jan. 2018
Offline
I'm encountering this issue in the latest 18.0.460 version. Did you ever get this issue solved? I'm getting an animation file in unreal, but its showing frame 1 for all frames.

edit - my only clue is that the animation seems to be missing proper bone names?
Edited by Okari - May 21, 2020 17:36:53

Attachments:
houdinierror.PNG (5.1 KB)

  • Quick Links