Packaging with Houdini Niagra Error

   2619   2   2
User Avatar
Member
4 posts
Joined: Aug. 2016
Offline
Hi Guys,
I am trying to package my game in UE4 with houdini niagra actor on it but I always got an error that says:

=================================================================================================================================
UATHelper: Packaging (Windows (64-bit)): ERROR: Missing precompiled manifest for ‘HoudiniNiagara’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in HoudiniNiagara.build.cs to override.
===================================================================================================================================

I have followed the installation video tutorial exactly the same way.
For specification:
I am on Windows 10 64bit and running Unreal Engine 4.25.3

Could someone please help me how to fix issue?
Thank you in advanced!
User Avatar
Member
72 posts
Joined: April 2014
Offline
I am getting the same issue, any recommendations?
User Avatar
Member
8 posts
Joined: Oct. 2013
Offline
I am having the same issue when building for Android.

Followed dpernuit's suggestion (for HoudiniEngine) and moved HoudiniNiagara from UE install to project, but no success.
Setting HoudiniNiagara from "Runtime" to "Editor" causes the built app to crash. (https://www.sidefx.com/forum/topic/62250/?page=1#post-288435)

Tried adding ‘PrecompileForTargets = PrecompileTargetsType.Any;’ or `bUsePrecompiled = true;`, but builds fail in both cases as well. Might have added it the wrong way, as I am not too familiar with the structure of these build.cs files.


Thanks for any help or thoughts on this.
  • Quick Links