Motion blur with changing topology?

   352   2   2
User Avatar
Member
5 posts
Joined: 5月 2015
Offline
Does anybody know how to get motion blur to work on something with changing topology (so from the velocity attribute) I cannot get it to work with any renderengine (tried karma and redshift)
I have it turned on on the rendergeometrysettings but I cannot get it to work even on a basic particle sim. Tried with cache sop, tried saving to .USD, nothing seems to work.

I'm probably just overlooking something but i've been trying since yesterday and I can't figure out why it's not working. Does anybody know what i'm doing wrong?
www.timvanhelsdingen.com
User Avatar
Member
3 posts
Joined: 7月 2013
Offline
In any situation where you need to have deformation motion blur, and the geometry changes between frames, you can usually modify the the geo so the topology remains consistent from shutter-open to shutter-close (typically 0.25 to +0.25 from center-frame). Assuming the geometry has some kind of consistent ID across the frame, I typically just use a timeshift with a round($FF)-0.25 to grab the geo at shutter open, and then attribcopy the from the true interpolated position (matching by id) any points that end up deleted mid-frame just remain at the shutter-open position (which is typically acceptable, though you can make it hold to the last-sampled mid-frame position too if you use a for loop with termination).

I've used this on many shows requiring highly non-linear motion on particle systems.
Edited by cteffects - 2020年5月8日 05:52:54
Charles Trippe
User Avatar
Member
3 posts
Joined: 11月 2013
Offline
Can't you use accel attribute?

Also this has some tips: https://www.youtube.com/watch?v=1FyZ9evoJVc [www.youtube.com]
  • Quick Links