The Houdini Engine for Maya plugin could not be initialized

   2569   4   1
User Avatar
Member
3 posts
Joined: 9月 2022
Offline
Hello I have some trouble using the Maya plugin in win10.

I am trying to use Maya plugin for Houdini19.5.493. I followed the instrusions on installation, then I open my Maya 2020, it reports this error:

The Houdini Engine for Maya plugin could not be initialized.
The path to libHAPIL is invalid. Please double-check the value in Houdini Engine>Preference.


Image Not Found


The HFS location I provided is C:/Program Files/Side Effects Software/Houdini19.5.493
and libHAPIL location is C:/Program Files/Side Effects Software/Houdini19.5.493/bin/libHAPIL.dll

Is the problem related to the path format? Maybe there are some more setup steps I missed? Thank you!!
User Avatar
スタッフ
451 posts
Joined: 8月 2019
Offline
How did you install Houdini and the plugin? Did you use the legacy installer, or the launcher?
User Avatar
Member
3 posts
Joined: 9月 2022
Offline
Hi, thank you for your reply!

I used the launcher to install everything, Houdini 19.5.493 itself and also the plugin. I noticed that it first checks the $HFS variable in the code so I manually added the path to environment variable and it is able to load the plugin now. So somehow the paths I put in the houdini engine preference are not recogonized.
User Avatar
Member
41 posts
Joined: 7月 2014
Offline
Thank you, inserting
HFS = C:/Program Files/Side Effects Software/Houdini19.5.493
in the maya .env made it work again.

Edit:
I think Sidefx changed something in the installation. Now there is a space between houdini and 19.5.493. So the path now has to look like this
HFS = C:/Program Files/Side Effects Software/Houdini 19.5.493
Edited by bobcat - 2024年2月12日 10:03:33
User Avatar
Member
1 posts
Joined: 5月 2019
Offline
shen25748
Hi, thank you for your reply!

I used the launcher to install everything, Houdini 19.5.493 itself and also the plugin. I noticed that it first checks the $HFS variable in the code so I manually added the path to environment variable and it is able to load the plugin now. So somehow the paths I put in the houdini engine preference are not recogonized.


Hello could you be more specific how to modify this??
  • Quick Links