Copy Stamping w/ Timeshift and Switch node stamping issue

   5325   6   1
User Avatar
Member
54 posts
Joined: Dec. 2011
Offline
I'v been struggling with this for a while, some one on here helped me get past some issues earlier but iv come to a problem i can't seem to figure out. i have a scene with multiple animated objects, im stamping these objects onto particles born from a collision and using the Hittime to timeshift the individual animations so they start playing at the time of impact. This all works but when i use the stamp expression in the switch node to get alternating animations at each point it will work for the first few hits perfectly but when the 3rd or 4th particle hit the timeshit on them doesn't work and everything starts jumping around in their animations individual timelines. I hope this all makes sence. If any one would be willing to take a look at the scene and see what im missing that would be great. i'v tried it with my proper geo animations and with basic primitives and its the same. Thanks
-Nick

Also the rand im using in the switch only seems to return 2 different values out of the 4 i have input?

Attachments:
Grow_Help.hipnc (2.6 MB)

User Avatar
Member
496 posts
Joined: July 2009
Offline
I might be mistaken, but to me it looks like a glitch in the matrix. Your stamp expression is correct and you don't kill particles so your point count doesn't change. I don't know why, but particle #3 hits the ground at frame 196 and at frame 197 its hittime*$FPS changes to -24. Don't really have an explanation for this.
Any other opinions on this ?

best,

Manuel
http://vimeo.com/user2522760 [vimeo.com]
http://stormbornvfx.com/ [stormbornvfx.com]
Manuel Tausch
User Avatar
Member
54 posts
Joined: Dec. 2011
Offline
I was killing the particle actually, i didn't think that was the issue because the first few were landing fine. Turns out it was a simple fix, thanks alot!
User Avatar
Member
496 posts
Joined: July 2009
Offline
lol .. in this case … makes more sense now
http://vimeo.com/user2522760 [vimeo.com]
http://stormbornvfx.com/ [stormbornvfx.com]
Manuel Tausch
User Avatar
Member
2624 posts
Joined: Aug. 2006
Offline
See attached Ive had a hack around with your scene and fixed a lot. The secret to debugging a scene is to strip it down to the basics and get parts working in order. Im sure you can finish the rest

Rob

Attachments:
simple_scene.hip (74.2 KB)

Gone fishing
User Avatar
Member
54 posts
Joined: Dec. 2011
Offline
this is awesome thanks, one problem i still have is in stamping the switch node it only ever seems to give me 2 or 3 of my inputs regardless of how many i have
User Avatar
Member
112 posts
Joined: Feb. 2010
Offline
Just multiply stamp expression by some value
floor(rand(stamp(“../copy1”,“copynum”,0)*20.5698) * opninputs(“../switch1”) )

or

stamp(“../copy1”,“copynum”,0)%opninputs(“../switch1”) will also work.
But it will not give you randomized output
  • Quick Links