crowd agent fbx import

   1938   3   1
User Avatar
Member
23 posts
Joined: Nov. 2015
Offline
Have several issues when creating an agent and importing a fbx animation (from mixamo).

1. Comes in without textures (the animation fbx), so I imported the character fbx and pointed the material for the agent to that one.

You can see in the attached render though comparing the character and the agent animation on the right that the render get's messed up.

2. Sometimes I just see bones in the viewport . Maybe a memory issue ?

3. With the animation fbx crowdsourced it plays the animation fine in the viewport, but when importing the basic character FBX in order to get the materials. I just see it jitter around frame 1 and the animation doesn't play. It does seem to render except I get the render issue in point 1.

Attachments:
mixamorender.png (167.7 KB)

User Avatar
Member
23 posts
Joined: Nov. 2015
Offline
3rd issue was solved. importing a t-pose fbx resets the animation frame range. So the jitter issue is solved.

But the render of the agent fbx still has the blob near the mouth.
User Avatar
Staff
3443 posts
Joined: July 2005
Offline
just a guess but the mouth blob looks like a couple of spheres are getting rendered - go into your fbx and make sure that ONLY meshes are displayed.

HTH
Michael Goldfarb | www.odforce.net
Senior Technical Director
SideFX
www.sidefx.com
User Avatar
Member
6 posts
Joined: March 2020
Offline
1. Comes in without textures (the animation fbx), so I imported the character fbx and pointed the material for the agent to that one.

How did you point the agents materials to the other materials network?
  • Quick Links