3D viewport zoom step size

   961   9   2
User Avatar
Member
85 posts
Joined: Feb. 2015
Offline
Hi everyone, I have a ‘silly’ issue with 16.5 : zooming close to an object in the viewport is pretty hard , because the zoom step size is huge.
Where can I remedy that ? I didn't find anything in ‘preferences’ or maybe something in houdini.pref file ?

thanks for 16.5 !
https://vimeo.com/user43710534 [vimeo.com]
User Avatar
Member
135 posts
Joined: March 2015
Offline
Hi, the mouse wheel scroll can be tricky to use for zoom as the increments can sometimes either be too big or too small. Have you tried using Alt+RMB instead?

Rob
User Avatar
Member
32 posts
Joined: Oct. 2015
Offline
Hello
I've notice it too
If you Shift+mouse scroll it goes slower
But it's true that the default behavior have changed

Ben
User Avatar
Staff
4152 posts
Joined: July 2005
Offline
Yes, it has changed. The old behaviour had a tendency to slow down almost to zero, making it so you'd never get where you want to go. Holding Shift down will give you a more precise zoom. Also resetting the pivot on the object you're looking at will also reset the zoom speed based on the pivot and camera location, giving you a better overall zoom rate.
User Avatar
Member
318 posts
Joined: Oct. 2012
Offline
Maybe it just takes some time to get used to but i also feel the steps seem way too big when close to an object.
User Avatar
Member
3755 posts
Joined: June 2012
Offline
Definitely would like a control like in Nuke ‘camera interaction speed’
Edited by fuos - Nov. 15, 2017 15:36:37

Attachments:
Camera interaction.png (173.0 KB)

User Avatar
Member
1418 posts
Joined: Sept. 2011
Offline
The zoom speed is based on clipping planes. You can hack the camera speed by manually entering clipping plane distances.
User Avatar
Member
85 posts
Joined: Feb. 2015
Offline
Benjamin Lemoine
Hello
I've notice it too
If you Shift+mouse scroll it goes slower
But it's true that the default behavior have changed

Ben
Hi , I didn't know about shift key , handy.
It is weird though, the behavior I had before no longer happens. zoom now feels like on 16.0 …

gui2one
https://vimeo.com/user43710534 [vimeo.com]
User Avatar
Member
1691 posts
Joined: June 2008
Offline
@jsmack: Ah, so that is why I am getting such jumpy camera navigation in my large scale scene. I had to extend my camera clipping planes so I could see my large environment.

It might be better if SideFX did not resuse the clipping plane for this feature but instead added another parameter to the camera object to offer more precise control in a large scene. The way it is currently implemented means the larger the scene, the more coarse your camera movements.
Edited by Enivob - March 6, 2018 11:42:33
Using Houdini Indie

Windows 7 32GB AMD FX8370 @ 4.0Ghz
nVidia 1070GTX 8BG RAM. Driver: 358.87
User Avatar
Member
1418 posts
Joined: Sept. 2011
Offline
Enivob
@jsmack: Ah, so that is why I am getting such jumpy camera navigation in my large scale scene. I had to extend my camera clipping planes so I could see my large environment.

It might be better if SideFX did not resuse the clipping plane for this feature but instead added another parameter to the camera object to offer more precise control in a large scene. The way it is currently implemented means the larger the scene, the more coarse your camera movements.

check the latest build, the zoom control was modified to not be so sensitive to the aspect ratio of the scene viewer and clipping planes. I'm finding navigation greatly improved.
  • Quick Links