Boolean not working with PolyExtrude

   363   6   1
User Avatar
Member
89 posts
Joined: May 2016
Offline
Hello, I noticed that when i try to shatter a geo that I created by extruding a surface with polyextrude, it simply doesn't work (won't shatter). If I use Extrude volume on the other hand, it works just fine. Am I missing something or is this a bug?

Thanks!
User Avatar
Member
593 posts
Joined:
Offline
Seconded. One problem I've noticed that the Boolean inverts polyextrude output when one sets a negative “Distance” value on the poly extrude. Expected behavior would be for the polyextrude to always output correct winding order as there is nothing strange of wanting to extrude a polygon downwards. (#82897)
B.Henriksson, DICE
User Avatar
Member
135 posts
Joined: Feb. 2017
Offline
with polyextrude, did you forget to Output Back ?
User Avatar
Member
89 posts
Joined: May 2016
Offline
vusta
with polyextrude, did you forget to Output Back ?

I had output back on.
User Avatar
Member
107 posts
Joined: July 2012
Offline
Would need to see the geometry, but there are a few rules for making sure you have clean geometry that is good for boolean fractures.
User Avatar
Member
89 posts
Joined: May 2016
Offline
Midasssilver
Would need to see the geometry, but there are a few rules for making sure you have clean geometry that is good for boolean fractures.

Here is a simple grid extruded. Turns out what Henriksson mentioned was the problem. When doing a negative extrusion, it doesn't work.

Attachments:
BOOLEAN_POLYEXTRUDE.hiplc (169.3 KB)

User Avatar
Member
1285 posts
Joined: Sept. 2015
Offline
When you do a negative extrusion just add a reverse sop after to change the normals.

Then it will work.
  • Quick Links