Labs terrain texture output not writing images.

   346   0   0
User Avatar
56 posts
Joined: Feb. 2017
I'm trying to output my heightmap textures using the Labs terrain texture output and it doesn't appear to be working correctly. I spent a bit of time trying to troubleshoot it by diving into the networks... It will write the temp .exr to the $HOUDINI_TEMP folder, but it doesn't run the Topnet. It gets this error:

Traceback (most recent call last):
File "generate_from_imageplanes_pythonprocessor1.generate", line 41, in <module>
File "generate_from_imageplanes_pythonprocessor1.generate", line 25, in MakeWorkItems
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.561/houdini/python2.7libs\pdg\", line 473, in _runOnMainThread
return self._runOnMainThread(work_item, wait, function, args, kwargs)
RuntimeError: Object of type 'tuple' is not an instance of 'none'

Error running Python callback 'Deferred Function Call':
TypeError: Object of type 'tuple' is not an instance of 'none'


I've tried 19.0.531, 561 and 589 both py 2 and python 3 versions. They all get the same error.
  • Quick Links