Is anyone having clicks getting stuck problems using wacom?

   28271   21   4
User Avatar
Member
2418 posts
Joined: Feb. 2012
Offline
I don't know how to repro this other than use Houdini for 5 mins or so but the last click quite often gets stuck so when I move the mouse over to another pane, the slider in most occurrence of this bug follows the cursor as if I am still holding down the button and changes values.

Most of the time it happens on sliders but sometimes in the network editor zooming, or the viewport still orbitting when I released the click and moved away from it.

So I have to go back over to the problem control and click again.

I am using 14.0.285 if that matters.

Anyone else having similar issues?
Senior FX TD @ Industrial Light & Magic

patreon.com/animatrix | gumroad.com/animatrixx
vimeo.com/animatrix3d | linkedin.com/in/animatrix3d
User Avatar
Member
258 posts
Joined:
Offline
Yeah, I am having this happen as well, very frustrating. Sometimes I can get it to release by either clicking the middle click on my pen or on the mouse.
User Avatar
Member
2418 posts
Joined: Feb. 2012
Offline
Thanks for confirming. I don't know if it's related but sometimes if I click a wrong item such as the help file button and leave a menu, you get into a click event that's extremely hard to break out of. This happened only a couple times so I am sure if it's relevant.
Senior FX TD @ Industrial Light & Magic

patreon.com/animatrix | gumroad.com/animatrixx
vimeo.com/animatrix3d | linkedin.com/in/animatrix3d
User Avatar
Member
75 posts
Joined: Oct. 2008
Offline
Yes, this happens to me, too. I have reported it as a bug, which has been confirmed by SideFX. Not sure when a fix is coming.
User Avatar
Member
2418 posts
Joined: Feb. 2012
Offline
aswaab
Yes, this happens to me, too. I have reported it as a bug, which has been confirmed by SideFX. Not sure when a fix is coming.

Thanks for reporting it. I couldn't manage to repro. It does happen when moving the slider on a sim too.

These are really frustrating because it happens 100s of times when you use Houdini daily.
Senior FX TD @ Industrial Light & Magic

patreon.com/animatrix | gumroad.com/animatrixx
vimeo.com/animatrix3d | linkedin.com/in/animatrix3d
User Avatar
Member
4172 posts
Joined: June 2012
Offline
It's kind of fun this bug, makes it feel sticky like honey

OsX version was fixed up in 14.0.314.

Edit: It may be a QT thingy - Nuke9 on OsX is also getting Wacom stickiness too when viewing a more complex tree and tweaking a paramenter further up the tree.
User Avatar
Member
2 posts
Joined: June 2014
Offline
Same problem here. With heavy simulation task wacom tend to clog.
User Avatar
Member
15 posts
Joined: May 2014
Offline
I've been getting this on H13 and H14 Windows 7.
I thought my Wacom was going…good to see other have this problem.

Wacom working stick-free on H13 and H14 on Linux.
User Avatar
Staff
1093 posts
Joined: July 2005
Offline
Hi All,

Just an FYI that I've committed a potential fix for Wacom tablet button ‘stickiness’ on Windows in tomorrow's Houdini 14.0.345 build.

Please give tomorrow's build a try.

Cheers,
Rob
User Avatar
Member
9 posts
Joined: Jan. 2014
Offline
Same issue, very annoying, still happening with 14.0.335, please fix!
Besides of that: great program, thank you SideFX, keep it up!

Edit: v.14.0.346 seems to have solved the issue, great!

Edit: I was too fast: v.14.0.346 has still this sticking problem…

Btw. I'm using: intuos3, win7 Pro 64bit SP1, latest wacom drivers: 6.3.11-4A

(Also I disabled wisptis to get rid of the stupid animated windows circles.)

It happens for example in the timeline…
User Avatar
Staff
1093 posts
Joined: July 2005
Offline
Ok, I committed another potential fix in tomorrow's 14.0.349 build. There was another issue dealing with just single button tablet clicks that sometimes occurred depending on the timing of the button press and release.

Give tomorrow's build a try and if there are still more issues then please post test steps on how to reproduce or submit a bug report.

Cheers,
Rob
User Avatar
Member
2418 posts
Joined: Feb. 2012
Offline
Thanks Rob for the fixes. I will try the latest build too but I am waiting for my tablet to arrive.
Senior FX TD @ Industrial Light & Magic

patreon.com/animatrix | gumroad.com/animatrixx
vimeo.com/animatrix3d | linkedin.com/in/animatrix3d
User Avatar
Member
66 posts
Joined: Sept. 2008
Offline
If this is only on Windows, have you made sure to disable the “use Windows ink” option in the Wacom preference application? It has caused wierd shit in my view ports if enabled… Just 2¥ from the sideline.

Also, you can find many extra interesting options for how the Os interprets the Wacom via gpedit (group policy editor) that I've used to fix minor annoyance issues when using wacoms in general…
“If your life is not NOW, you're already dead…”
From Chrizto's book of truths
User Avatar
Member
15 posts
Joined: May 2014
Offline
I gave the latest build a thorough test this weekend and can say it is much improved, though not 100%. It's hard to put a finger on exactly reproducing it. I have all of the windows 7 tablet input functions disabled. Just using Wacom software with an Intuos 3…If you use, you should experience sticky pointer behaviour at least a few times over 5-10 minutes of general Houdini magic making.
But again, it is much better now. Thanks so much for the work on getting this resolved.
User Avatar
Member
66 posts
Joined: Sept. 2008
Offline
I'm using an Intous4 on the 0.335 release, and have no trouble, but I'm on windows 8.1…
“If your life is not NOW, you're already dead…”
From Chrizto's book of truths
User Avatar
Staff
1093 posts
Joined: July 2005
Offline
northupfox
I gave the latest build a thorough test this weekend and can say it is much improved, though not 100%. It's hard to put a finger on exactly reproducing it. I have all of the windows 7 tablet input functions disabled. Just using Wacom software with an Intuos 3…If you use, you should experience sticky pointer behaviour at least a few times over 5-10 minutes of general Houdini magic making.
But again, it is much better now. Thanks so much for the work on getting this resolved.

Glad to hear that it's gotten better. Sucks though that you are still hitting issues. I haven't been able to reproduce the sticky pointer since the latest tablet fixes so if you do manage to find reproducible test steps then please let me know. It would help a lot!

Cheers,
Rob
User Avatar
Member
66 posts
Joined: Sept. 2008
Offline
Why not run the program through a debugger and send the output file?
“If your life is not NOW, you're already dead…”
From Chrizto's book of truths
User Avatar
Member
370 posts
Joined: Nov. 2008
Offline
Thank you Rob,

I tested it with 14.0.349 VC11 on Windows 7 with Intuos 4 (latest drivers 6.3.11-4 and Use Windows Ink turned off) and it looks like that reported problems were fixed.

Try that build (and drivers) or newer one.

Cheers,
Petr
User Avatar
Member
2418 posts
Joined: Feb. 2012
Offline
I am using the latest build with Intuos 6 (pro) for the last week and it still has some issues. Not as bad as before so it's improved for sure but I notice sticky behaviour when using the parameters panel. For example I change a parameter, and the Render View has to update along with the viewport and it's not realtime, the parameter slider sticks.
Senior FX TD @ Industrial Light & Magic

patreon.com/animatrix | gumroad.com/animatrixx
vimeo.com/animatrix3d | linkedin.com/in/animatrix3d
User Avatar
Member
19 posts
Joined: Oct. 2014
Offline
i had this problem also,

i believe its due to the different monitor resolution
  • Quick Links