Game Tools | AliceVision

   10131   26   3
User Avatar
Member
6999 posts
Joined: July 2005
Offline
Hi Paul,

I just noticed this created in $HIH:

\tmp\AV_Cache\testApple

However I'm on Linux so… I'm guessing some Windows-specific code snuck in?

That's created as a single directory. Also given how big that could potentially be, is $HOME/houdini17.5 the best place for it? Why not $TEMP? I could be missing something though.

17.5.253 Linux

Cheers,

Peter B
User Avatar
Member
10 posts
Joined: May 2015
Offline
Hi Paul, thanks for adding a linux version!

I'm having some problems trying to get this new version to run on centos7 and houdini 17.5.128 core, I get an error message after every stage similar to this: Step 01_Camera_Init failed! See log for details!

It writes the folder structure in the av_cache folder, and puts the 6 images (mini treemonster example) in the first folder, and then writes 2 blank log files (init_log.txt, init_errorlog.txt) into each following folder. No errors in the console either.

Tried creating new project/hip name to create a clean cache folder, but same thing happens.

Its up and running just fine on win 10 pro, 17.5.258 indie at home.

Cheers,
Matt
Edited by Matt Morris - June 12, 2019 12:54:45
User Avatar
Member
21 posts
Joined: Nov. 2006
Offline
Hi, I also get on error on linux (ubuntu)
aliceVision_cameraInit: error while loading shared libraries: libaliceVision_sensorDB.so.2: cannot open share object file:No such file or directory
User Avatar
Staff
197 posts
Joined: July 2015
Offline
Hi,

I've been looking into these issues and they don't seem to be Houdini issues. They appear to be some problems with the binaries themselves. Please submit your issue here if possible: https://github.com/alicevision/AliceVision/issues [github.com]

Paul
Paul Ambrosiussen
Technical Artist, Freelance
twitter.com/ambrosiussen_p
User Avatar
Member
37 posts
Joined: Dec. 2010
Offline
I was also getting error about “init_camera failed”. Backed up to version 2.1.0 instead of 2.2.0 and something has changed. But I still have errors. This time it's on step 06_Prepare_Dense_Scene AliceVision…
ERROR: unrecognized option ‘–evCorrection’
ERROR: unrecognized option ‘–computeNormalMaps’
ERROR: unrecognized option ‘–outputMesh’
ERROR: unrecognized option ‘–inputMesh’
ERROR: unrecognized option ‘–useUDIM’

I guess may be that happens because I switched to v 2.1.0 and it doesn't support some features ? But 2.2.0 doesn't work at all.
Edited by maxpayne - Dec. 15, 2019 01:28:53
User Avatar
Member
13 posts
Joined: Oct. 2009
Offline
I've been getting this error:

Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "opdef:/labs::Sop/av_photogrammetry::3.0?PythonModule", line 4, in ManualCook
File "opdef:/labs::Sop/av_initialize::3.0?PythonModule", line 71, in cookNode
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.348/houdini/python2.7libs\hou.py", line 11368, in cook
return _hou.Node_cook(*args, **kwargs)
OperationFailed: The attempted operation failed.
Error while cooking.

I've found that if I put in a different project name on the initialize tab, then it runs fine.
running Houdini 18.0.348 with AliceVision 2.2.0
Edited by medendog - March 22, 2020 23:03:19
User Avatar
Member
18 posts
Joined: Jan. 2017
Offline
Hi!
I love this but also get an error when running the av_meshing node

ERROR: unrecognised option "--forceTEdgeDelta"

windows, Houdini 18.5.462 and SideFX labs 18.5.462. The previous nodes (init, analyze, structure, depth) seem to run fine. The issue seems to be in the 09_meshing python call. Same error comes when I use the photogrammetry node. I used 3 input images from Sample Content 1.

Cheers!
  • Quick Links