Batch renders with Arnold using PDG

   341   4   0
User Avatar
Member
2 posts
Joined: July 2019
Offline
Hi,

I would like to render sequences and wedges with Arnold using PDG/TOP.

My current setup uses a ROP Fetch node that points to the out/arnold node. I plug-in the rest of my TOP network (wedges, …) as input to that ROP Fetch node.

This renders the correct sequence of images, although the shaders are missing (my geometry is all pink).

I am using Arnold's Standard Surface Shader in SHOP, which I assign to my geometry.

I read online that SHOP was deprecated but can't figure out how to define an Arnold shader without SHOP.

Any suggestions? Is there another way to render with Arnold using PDG than using a ROP Fetch node?

Thanks!
User Avatar
Staff
544 posts
Joined: Sept. 2012
Offline
This sounds more like a shader issue than a PDG issue. I’ve pointed your question at our rendering folks, but with SIGGRAPH on our door steps please expect some delays in our reply.
Edited by kenxu - July 27, 2019 10:01:42
- Ken Xu
User Avatar
Staff
1131 posts
Joined: July 2005
Offline
Houdini is backwards compatible and still supports SHOPs in older setups. So if you still have the Arnold's Standard Surface Shader SHOP, it should work fine.

Ultimately, it's up to the Arnold's ROP to interpret the shader networks (be it SHOPs or VOPs) and translate it to a format consumable by Arnold renderer. It may be worthwhile to ask on Arnold's forum about it.
User Avatar
Member
1 posts
Joined: April 2017
Offline
It looks like i ran in the very same issue. Is this actually an issue? I made a simple testscene with a wedge, a ropgeometry and a ropfetch. The material is set by a material node right in the geo-node. THe shader lives in “shop/arnold_vopnet1” The arnold rop is rendering fine by itself but if the render is triggered by the ropfetch the shaders get lost. The wedge is working fine though. I don't seam to find an answer in the arnold forum either. Any direction towards a solution is very much appreciated.

THANKS!
User Avatar
Staff
544 posts
Joined: Sept. 2012
Offline
Could you kindly post something on the Arnold forum, in that case? We’ll raise this as well with them whenever we get to meet. If you could upload a reference file, we can potentially work with them to correct the issue. Note however this may take a while, as it requires coordination between our two companies.
Edited by kenxu - Sept. 18, 2019 17:53:46
- Ken Xu
  • Quick Links