no openCL device available

   1578   8   3
User Avatar
Member
63 posts
Joined: Nov. 2015
Offline
I completely reinstalled everything including windows on my workstation
now Houdini doesn't recognize my 1080 Ti

has this something to do with windows being windows in it's newest form?

NVidia Driver is also the latest (416.94)

Attachments:
houdiniNoOpenCL.PNG (12.2 KB)

User Avatar
Member
1 posts
Joined: July 2015
Offline
Unfortunately I have the same issue with my 2080 Ti.

Tested configurations:

Houdini 17.0.403
Houdini 17.0.352

NVIDIA 416.94
NVIDIA 416.81
User Avatar
Member
16 posts
Joined: Aug. 2018
Offline
Christoph F
I completely reinstalled everything including windows on my workstation
now Houdini doesn't recognize my 1080 Ti

has this something to do with windows being windows in it's newest form?

NVidia Driver is also the latest (416.94)

Same issue for me
User Avatar
Member
5 posts
Joined: June 2013
Offline
I rolled my nVidia driver back to 416.34 and it works now.

Win 10 64bit
2 x 1080Ti
Houdini Indie 17

416.94 and 416.81 did not work.
User Avatar
Member
55 posts
Joined: Feb. 2014
Offline
Same issues here. No solution in rolling back drivers.
Win 10 64bit
1 x 1080Ti
1 Titan Black
Houdini Indie 17
User Avatar
Staff
667 posts
Joined: July 2006
Offline
Thank you for reporting this issue. It turns out that Microsoft changed their specifications for where graphics drivers can write to the registry, which in turn means changes were required for the OpenCL ICD loader (the small bit of code that loads the various OpenCL drivers from different vendors). We ship a custom version of that ICD loader under Linux and Windows so that the built-in CPU OpenCL driver is always available, but have not yet updated it to obey Microsoft's new conventions. We're working on a fix that should be out soon.
User Avatar
Staff
667 posts
Joined: July 2006
Offline
By the way, as a temporary workaround, you can go to the bin directory of your Houdini installation (usually something like C:\Program Files\Side Effects Software\Houdini 17.0.356\bin) and temporarily move or rename the OpenCL.dll file there. That will cause Houdini to use the system-wide OpenCL loader installed by NVIDIA, which should find your GPU driver. You'll lose the built-in CPU driver, however, but you might not care about that.
User Avatar
Staff
667 posts
Joined: July 2006
Offline
This issue should be fixed in today's Production Build of 17.0.416
User Avatar
Member
1 posts
Joined: Nov. 2016
Offline
Corrected by build 17.0.416 Thank you for the explainations and the quick fix !
  • Quick Links