viewport keeps changing the camera

   6163   14   6
User Avatar
Member
7 posts
Joined: Feb. 2014
Offline
I don't think that was always the case, but since a recent update every time I go between SOP levels the active viewport changes to a “No cam”, rather than maintaining the previously selected render camera.
Is there a new setting to prevent this from happening? I find my self re-selecting the render camera in the viewport all the time as I navigate my network.
User Avatar
Member
1755 posts
Joined: March 2014
Offline
Do you have lock camera toggle off? Although just going in and out of SOPs shouldn't deselect your cam even if the lock toggle is off.
I don't have this problem on my end.
Edited by anon_user_89151269 - April 9, 2019 10:55:09

Attachments:
lock.jpg (51.1 KB)

User Avatar
Member
6235 posts
Joined: Sept. 2011
Offline
This annoying behavior seems like a bug that crept in recently.
User Avatar
Member
7 posts
Joined: Feb. 2014
Offline
McNistor
Do you have lock camera toggle off? Although just going in and out of SOPs shouldn't deselect your cam even if the lock toggle is off.
I don't have this problem on my end.
Image Not Found


Locking the camera prevents this from happening, but that's not a good solution as I may accidentally change the render camera position. I noticed when setting the triple option above the camera selection to view the rest of the scene, also prevents this issue.
I am in houdini Indie 17.0.459
Which version are using?
I will report it as a bug

thanks
User Avatar
Member
1755 posts
Joined: March 2014
Offline
ch3
Locking the camera prevents this from happening, but that's not a good solution as I may accidentally change the render camera position.

It's probably best to make a habit of putting keys on your camera transformations. I made this habit from working in other programs with no camera lock function, which it seems like it's there so that users have one more thing they can forget about.

I'm using 17.5…
Edited by anon_user_89151269 - April 9, 2019 11:15:44
User Avatar
Member
6235 posts
Joined: Sept. 2011
Offline
ch3
Which version are using?
I will report it as a bug

17.0.506 and 17.5.204

The camera doesn't pop off because of changing contexts, its because the visible objects list changes. The same thing happens if the display filter is changed from ‘Hide Other Objects’ to ‘Ghost Other Objects’ or to ‘Show All Objects’, without changing context. If the filter is on ‘Hide Other Objects’ then the camera pops off the viewer when changing context as well.
User Avatar
Staff
1054 posts
Joined: July 2005
Offline
I think this has always been the case. When you're in Hide Other Objects and at the SOP level, you're actually in the local space of the object instead of world space. This is not purely a visibility setting. In Houdini, we conflate it with which space the viewer is showing. When the viewer changes coordinate systems like this, it also transforms the view so that there is no sudden jump. It is because of this change in view that we have to unset the camera.

It's like this for historical reasons. We realise how weird this is and will be separating the two concepts (eventually).
Edited by Ondrej - April 9, 2019 14:33:56
User Avatar
Member
699 posts
Joined: Dec. 2006
Online
This is a bug. I just tried Houdini 15 and it didn't do this, not matter if “hide other objects” was on or off. I don't recall it happening in 16 or 16.5, so I don't know when it got introduced but it was fairly recently. It drives me nuts. I will file a bug report, I suggest everyone else bothered by this do the same.
Sean Lewkiw
CG Supervisor
Machine FX - Cinesite MTL
User Avatar
Staff
1054 posts
Joined: July 2005
Offline
You're right that it doesn't seem to do this in H15. I suspect that a fix for some other problem caused this. I'll take a look.
User Avatar
Staff
1054 posts
Joined: July 2005
Offline
Found the problem. Should be fixed in 17.0.548 and 17.5.223.
User Avatar
Member
7002 posts
Joined: July 2005
Offline
There will be much weeping of joy in our building… or at least, less gnashing of teeth
User Avatar
Member
27 posts
Joined: July 2015
Offline
This seems to still be happening. I'm on 17.5.293. Doesn't matter if the viewport is locked or not. It will randomly flip my perspective upside down and the only way to recover is to press space+g to reset the screen. It's happening constantly and also causing my redshift render view to bug out.
User Avatar
Member
59 posts
Joined: April 2018
Offline
drossxyu
It will randomly flip my perspective upside down and the only way to recover is to press space+g to reset the screen. It's happening constantly and also causing my redshift render view to bug out.
This is a different issue. It's related to Redshift and due to recent changes in the HDK. A fix is already available in RS3.0.04. See here [www.redshift3d.com] in the RS forums for more info.
User Avatar
Member
1755 posts
Joined: March 2014
Offline
A different issue, reproducible like this:
- orbit around your selection until the negative half-space of Y gets above the horizon line; you're basically upside-down and your orbiting control is “inverted” now
- Space + F to frame your selection and fix the inverted control
- going back to normal view (positive Y half-space) and your orbiting control is inverted again, so Space + F to fix it

Not sure if it's a bug, but I'm suspecting that it is, because this doesn't happen when locked in a user created camera, only when in the Houdini's implicit one.
Edited by anon_user_89151269 - July 8, 2019 11:45:52
eikonoklastes
Member
213 posts
Joined: April 2018
Online
This issue persists in 17.5.413.

Edit: turns out it's a Redshift bug. Updating to the latest Redshift resolves this.
Edited by eikonoklastes - Nov. 3, 2019 04:04:48
  • Quick Links