Houdini Niagara Updates

   10836   42   51
User Avatar
Member
3 posts
Joined: Aug. 2017
Offline
Hi all. I'm trying to use the Houdini Niagara rop to bring an RBD simulation to Unreal and struggling in transferring the correct orientation for the pieces. Did anyone manage to achieve this?
I managed to create the correct orient attribute in Houdini, but how do I feed it to Niagara? What module should use this attribute? I tried “orient mesh to vector” with overriding the quaternion, but it gives the wrong orientation whatever I do.

edit - I found a solution - I had to generate a fake N from orient inside Houdini and export both orient and N, then I used this normal as Look at the direction in “orient mesh to vector” module + orient as quaternion override + N as reference axis vector + 1 override incoming orientation. This feels like an overly complex answer to a simple rotation question.

But I have new questions:
1 - Niagara side - When I try to convert emitter to GPU sim, I get an “invalid type for index in NiagaraEmitterInstance.ush”. Is it even possible to use GPU?
2 - Houdini side - After the first frame I have a weird position offset on each piece. I think it could be some pivot offset, but why it's only starting on frame 2? I mean It looks ok in sim right after RBD but if I delete geometry and instance exported pieces on rbd points, this offset appears.
Edited by axess21 - Nov. 6, 2020 05:27:22
User Avatar
Member
11 posts
Joined: May 2017
Offline
Hi There

I am trying to create a looping particle animation and there seems to be a weird delay in the beginning of animation. I have reduced my data to 1 point and 10 frames and created a super simple position sampler, but the problem still presists.
In Particle Update my ‘Test Script’ just reads the position value of the particle 1 at frame 1 (the position is 0,0,0 here) and passes it on to the Houdini particle position parameter. But I have to go to approx. 0.03 on the timeline before the particle shows up.

WHAT am I not understanding here?!?

Cheers
Jacob

Attachments:
HouNiagara_problem1.JPG (167.0 KB)
HouNiagara_problem2.JPG (154.1 KB)

User Avatar
Member
62 posts
Joined: July 2013
Offline
Could we please have the Unreal 25.4 compile? I tried to get into this and 25.4 is the only one Epic is giving me but the tools are compiled for 25.3. Thanks!
- “spooky action at a distance”. Albert Einstein
  • Quick Links