Official Labs Vertex Animation Textures 3.0 FAQs and Links

   14660   60   19
User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline


Hi everyone,

I'm creating this thread so that all VAT3 related questions can be gathered here, as there are a lot of questions about VAT in separate posts recently. I still owe you folks the VAT3 Complete Guide Part 2 PDF and some tutorial videos about advanced setups. Those will come soon, probably in Nov 2021.

Please feel free to post your questions below. I will try to collect questions and answers together as FAQs in the first 3 posts in this thread and keep them updated.

The first post of this thread will be reserved for links, the second for Unreal FAQs, and the third for Unity FAQs.

Cheers,
Mai



Vertex Animation Textures 3.0 Complete Guide PDFs and Demo Projects
https://drive.google.com/drive/u/1/folders/1Tq7CExY8k103MJDVbi96GqIBm8P6S0Qn [drive.google.com]
Contents of this Google Drive folder will always reflect the latest updates.

Vertex Animation Textures 3.0 Complete Guide: Part 1
https://www.artstation.com/artwork/zOyke6 [www.artstation.com]

Vertex Animation Textures 3.0 Complete Guide: Part 2
https://www.artstation.com/artwork/5XJZV8 [www.artstation.com]
...
There are 4 more planned posts to come to complete Part 2.

Vertex Animation Textures 3.0 in Unreal (Beginner)
https://www.sidefx.com/tutorials/vertex-animation-textures-for-unreal/ [www.sidefx.com]

Vertex Animation Textures 3.0 in Unity (Beginner)
https://www.sidefx.com/tutorials/vertex-animation-textures-in-unity/ [www.sidefx.com]

Conditional VAT Demo Project (Advanced)
https://www.sidefx.com/contentlibrary/conditional-vat/ [www.sidefx.com]
Edited by MaiAo - Oct. 30, 2021 16:12:42

Attachments:
VAT3.0 Image.png (3.4 MB)

Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
This reply is a place for FAQs with VAT3.0 in Unreal Engine 4 and 5. It will be kept up-to-date.


Q: My VAT in UE looks broken. What do I do?

Most often, the issues with VAT in UE4/5 (more on UE5 in the next question) can be resolved (or at least tracked down) by one of the following steps. If none of the steps identifies or fixes the problem, please don't hesitate to reach out to us at support@sidefx.com and submit it as a "question". We typically respond within a day or two to questions.




Q: Why is my VAT mesh full of holes in UE5?

UE5 changed some mesh UV implementations which can cause VAT mesh to look glitched. It happens often with the Dynamic Remeshing (Fluid) mode. To address this issue, you can simply go to UE5 Mesh Editor and turn on UE4 Compatible UVs. If that does not work even after you restart UE, try turning off UE4 Compatible UVs and turning on Use Full Precision UVs (which is somewhat more expensive, only use if absolutely necessary).






Q: Why does my fluid sim via Dynamic Remeshing mode have flickering normals?

This is due to the changing topology of the geometry that is remeshed every frame. This problem may be more noticeable when the poly count is low and when surface has many rapidly changing details. You can help alleviate this issue by redistributing more poly count to the player-facing areas of your animation by adding a retention attribute when you poly reduce.

I will be working on a more permanent solution to spatially and temporally stabilize the normals for this kind of animations. The solution will probably be released as a standalone SOP that stabilizes your geometry before it is sent to VAT ROP.
Edited by MaiAo - June 3, 2022 17:04:50

Attachments:
VAT3-UE5 Glitch 01.png (3.7 MB)
VAT3-UE5 Glitch 02.png (3.6 MB)
VAT3-UE5 Glitch 03.png (3.7 MB)
POWERPNT_F0DskCruWu.jpg (574.3 KB)

Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
This reply is a place for FAQs with VAT3.0 in Unity. It will be kept up-to-date.


Q: Why does VAT3 Unity package throw NullReferenceException upon import?

This issue has been fixed (tested on Unity Official Release 2021.3.0f1 Universal Render Pipeline).

In some earlier versions, including the official release 2021.2.7f1, Sub Shader Graph Properties which do not have the Precision setting, such as Keyword, Dropdown, will cause this error.

There is a line in Unity's ShaderSubGraphImporter.cs
GraphPrecision propGraphPrecision = prop.precision.ToGraphPrecision(graph.graphDefaultPrecision);
that references
prop.precision
and likely this is causing issues with the Keyword and Dropdown properties present in VAT3 shaders.
Edited by MaiAo - May 31, 2022 21:57:42
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
31 posts
Joined: June 2017
Offline
Thank you for getting this together.

Motion blur workflow for Unreal/Unity please.

edit:

I see the art station slide. Nevermind, thank you!
Edited by commedieu - Oct. 30, 2021 16:29:19
User Avatar
Member
1 posts
Joined: Oct. 2021
Offline
MaiAo
a placeholder for FAQs with VAT3.0 in Unreal Engine 4 and 5
Hi,

Thanks for creating this forum. I have been struggling with using fluid vertex animation in Niagara. The fluid mesh auto plays back in the scene but if I try to use it in Niagara (Mesh renderer & apply instance material), it starts to flicker and goes all over the place. I followed the tutorials above in setting it up. Is there something else I need to do?
User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
damilola
MaiAo
a placeholder for FAQs with VAT3.0 in Unreal Engine 4 and 5
Hi,

Thanks for creating this forum. I have been struggling with using fluid vertex animation in Niagara. The fluid mesh auto plays back in the scene but if I try to use it in Niagara (Mesh renderer & apply instance material), it starts to flicker and goes all over the place. I followed the tutorials above in setting it up. Is there something else I need to do?

Did you use the legacy parameter workflow that's required to work with mesh particles? It's described in the guide part 1.
Edited by MaiAo - Nov. 16, 2021 16:41:19
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
1 posts
Joined: Dec. 2021
Offline
Does it have any limitations for use with Niagara (amount of polygons or types)? My engine crashes when I try to use RBD VAT in Niagara. Tried it in both versions - 4.26 and 4.27. Made all settings in Houdini and material for instances (checkbox before export, set bounds box in material parameters).
As soon as I put a mesh with VAT in Niagara Mesh Renderer, compilation of shaders and then crash.

I thought I was doing something wrong and downloaded VAT Demo Project from this topic. Use mesh from ISM_HISM folder with material M_Rigid_Instanced and try put it in Niagara - 1 Burst, Mesh Renderer, override material, choose M_Rigid_Instanced - crash.

Does RBD VAT work with Niagara?

Attachments:
Untitled-1.jpg (874.0 KB)

User Avatar
Member
6 posts
Joined: Aug. 2019
Offline
Hi,
i just installed the newest version of unity 2022.10b2.2474 and imported my three folders (geo, tex, unity) from houdini. Sadly my unity material (in folder 'unity') appears pink. The shader is missinig? It sais: Hidden/InternalErrorShader. Could you help me?

All best and thanks for vat3.0, it seems to be supercool

dominik

PROBLEM fixed by myself

I missed to install the 'sidefx vertex animation textures' package in unity. Helpful is the the quick guide inside houdinis vat-node under tab 'realtime shaders.

All best.
Edited by dominiksartor - Dec. 22, 2021 14:19:44
User Avatar
Member
6 posts
Joined: Aug. 2019
Offline
Hi all,

Is there any possibility to improve the shadow quality? My softbody VAT -animation works fine. But it looks awful compared to my other animations, which are based on shape keys. Shadows are very strong and have low quality. Any ides?

Thank you and a good start into 2022,
dominik
User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
dominiksartor
Hi all,

Is there any possibility to improve the shadow quality? My softbody VAT -animation works fine. But it looks awful compared to my other animations, which are based on shape keys. Shadows are very strong and have low quality. Any ides?

Thank you and a good start into 2022,
dominik

Hi, could you provide some example screenshots of the shadows/settings or possible project files?
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
2 posts
Joined: April 2019
Offline
Hello,

I am attempting to use the provided VAT3_Tutorial_Simulations.hip with H19.0.455 to generate the cloth/soft body simulation and export to Unity URP 2021.2.5f1.

After setting up the Unity assets (mesh/textures/material) following the video instruction, the mesh appears black in the Unity viewport and does not animate. No errors are displayed in the console.

Any suggestions on how to proceed? Thanks!

Attachments:
UnityVAT01.png (65.6 KB)

User Avatar
Member
1 posts
Joined: Nov. 2020
Offline
MaiAo
This reply is a placeholder for FAQs with VAT3.0 in Unity. It will be kept up-to-date.


Q: Why does VAT3 Unity package throw NullReferenceException upon import?

It appears that in recent versions, including the official release 2021.2.7f1, Sub Shader Graph Properties which do not have the Precision setting, such as Keyword, Dropdown, will cause this error.

There is a line in Unity's ShaderSubGraphImporter.cs
GraphPrecision propGraphPrecision = prop.precision.ToGraphPrecision(graph.graphDefaultPrecision);
that references
prop.precision
and likely this is causing issues with the Keyword and Dropdown properties present in VAT3 shaders.

This error didn't exist with previous Unity versions. I'm in contact with Unity to see if they can fix this (as of Jan 07, 2022). I technically can implement a workaround by turning those precision-less properties into simple Booleans properties, but that is not ideal for performance.
any news for the fix, I am using Unity 2021.2.3f1 and URP 12.1.1 , I am getting Subshader error

Attachments:
VATbug.JPG (55.1 KB)

User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
infinate
Hello,

I am attempting to use the provided VAT3_Tutorial_Simulations.hip with H19.0.455 to generate the cloth/soft body simulation and export to Unity URP 2021.2.5f1.

After setting up the Unity assets (mesh/textures/material) following the video instruction, the mesh appears black in the Unity viewport and does not animate. No errors are displayed in the console.

Any suggestions on how to proceed? Thanks!

Please go to the SideFX Vertex Animation Textures package folder inside Unity Editor and try saving one of the sub shader graphs (marked with SSG in their names). If you get an error, then it's related to this: https://www.sidefx.com/forum/topic/81422/?page=1#post-350762 [www.sidefx.com]
Edited by MaiAo - Jan. 10, 2022 18:36:49
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
2 posts
Joined: April 2019
Offline
MaiAo
Please go to the SideFX Vertex Animation Textures package folder inside Unity Editor and try saving one of the sub shader graphs (marked with SSG in their names). If you get an error, then it's related to this: https://www.sidefx.com/forum/topic/81422/?page=1#post-350762 [www.sidefx.com]

Thanks for the rapid response. I did receive the error once I updated the shader asset. Look forward to updates!
Edited by infinate - Jan. 10, 2022 22:30:33
zampha
Member
10 posts
Joined: May 2016
Online
Hi
I'm using VAT 3.0 to unreal 4.26. I can export normally fine, but when I've tried to export for use with Niagara mesh the mesh appears covered in holes. I've followed the guides on artstation accurately as far as I know so any pointers would be appreciated!
Edited by zampha - Jan. 12, 2022 12:42:57

Attachments:
Screenshot 2022-01-12 173908.jpg (38.1 KB)

User Avatar
Staff
89 posts
Joined: Feb. 2021
Offline
nadmai
Hi
I'm using VAT 3.0 to unreal 4.26. I can export normally fine, but when I've tried to export for use with Niagara mesh the mesh appears covered in holes. I've followed the guides on artstation accurately as far as I know so any pointers would be appreciated!

Did you get a chance to try the debug steps? One possible solution, depending on the size of your texture, is to turn on Use Full Precision UVs.
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
zampha
Member
10 posts
Joined: May 2016
Online
Thanks Mai, full precision UVs did the trick, thanks for the tip!
User Avatar
Member
1 posts
Joined: Jan. 2021
Offline
MaiAo
This reply is a placeholder for FAQs with VAT3.0 in Unreal Engine 4 and 5. It will be kept up-to-date.
Hi!! Great stuff.

I am currently exporting my high-detail fluid sim into Unreal 4.26, but I keep getting these weird artifacts, these are triangles in the mesh that start flickering. Is not full-precision UVs as I already tried, and is not mesh resolution, as I have also tried to solve with several polygon counts the problem still persists.

If I view the effect from some distance it looks really good, but as soon as I aproach it and look it up-close I see these triangles flickering all over the place. (I need it to be high detail as it is going to be close to my camera)

Thanks in advance!!
User Avatar
Member
1 posts
Joined: Jan. 2022
Offline
Hello MaiAo

I follow the tutorial.Everything looks great in tutorial,but the mesh's shadow in my unreal project is weird.I don't know why.Could you help me?

Attachments:
20220211083856.png (486.6 KB)

User Avatar
Member
1 posts
Joined: April 2019
Offline
I I am trying to make Vat 3 work for almost a week now And nothing seem to work. I narrow down everything from Vat 2 2.1 to 3.

I use Houdini 19.0.507
I use Unity 2021.2.8f1

For a wild I tried my own simple Rigid simulation - not working I just tried to make Simon tutorial to work( and it does not)

rigth now it look, like cluster of thing.

I want to say I do not get shader error, so it work theoricly.

someweird science is going on here.

https://media.giphy.com/media/JQiKSufnq7P3piV40i/giphy.gif [media.giphy.com]

I mostly know to debbug my stuff but this hell no.

I would really need some help please.
  • Quick Links