Motion blur incorrect

   3418   7   2
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Hello,

I have some difficulty with my motion blur which largely exceeds my real motion (cf. screenhot).
I would like to know if it's a common problem and how you think it can be resolved.

Thank you.

Attachments:
motionBlur_02.jpg (108.3 KB)
motionBlur_01.gif (195.5 KB)

User Avatar
Member
2578 posts
Joined: June 2008
Offline
It is hard to say without seeing the HIP file but you have to dial it back, right? Locate your velocity attribute and multiply it by 0.1.
Using Houdini Indie 20.0
Windows 11 64GB Ryzen 16 core.
nVidia 3050RTX 8BG RAM.
User Avatar
Member
41 posts
Joined: June 2010
Offline
You might also want to check your scene scale. If you are object merging into a scaled object, your motion blur might not look correct
~t.goat
User Avatar
Member
12602 posts
Joined: July 2005
Offline
It's common for forwardly extrapolated motion blur to overshoot when a motion discontinuity like this happens (hitting the bottom of the bowl) and so you might try adjusting your Shutter Offset.
Jason Iversen, Technology Supervisor & FX Pipeline/R+D Lead @ Weta FX
also, http://www.odforce.net [www.odforce.net]
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Hello all, Thanks for your comments.

I directly import my simulation files “*.bgeo.sc” without scaling.
But when I build my simulation I scale some parameters like Gravity force (-980.665) and Spacial Space (0.01) and Mass Scale (0.01).
That's because I scale my collider object by 100 to allow me to use a small emitter (start to fill a barrel of 600L with an emitter of 3cm diameter).

And I try to play with the Shutter Offset but without succes (just reduce this problem but dont resolve it entirely).
The fact is my liquid fall quickly and if I reduce my velocity parameter (ex. by 0.1) I don't have enough blur.

Can you tell me where I'm wrong ?
I've joined my project with the first 25 frames simulation cached files.
Thanks.

Attachments:
houdini_motionBlur.rar (25.4 MB)

User Avatar
Member
143 posts
Joined: Feb. 2012
Offline
Dont touch the shutter, for me that usually just adds in more problems down the road.
You want to either lower the magnitude of v if it is going above a certain speed, or blur the magnitude of v, both easily achieved by a wrangle/vop node.
This is a common thing to do for any type of sim.
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Thank you,
I clamp my velocity in an attribute VOP from -40 to 40 and, even if it's not perfect, it considerably reduce this overflow (cf. screenshot).

Attachments:
motionBlur_03.jpg (126.3 KB)
motionBlur_03_clamp.jpg (56.2 KB)

User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Just to conclude,

I need to clamp my velocity vector length instead of clamp individually my velocity vector components (x, y, z) individually like I do in the attribute VOP screenshot of my last post ops: .
In order to not change velocity direction.

To polish more :idea: I compute the distance from each liquid point to the collision object (use the velocity for direction) and determine the lower velocity length limit (cf. screenshot).

Attachments:
motionBlur_04.jpg (107.3 KB)

  • Quick Links