Houdini 19 doesn't load AT ALL on Ubuntu 21.10

   43136   117   19
User Avatar
Member
232 posts
Joined: March 2009
Offline
Thank you. So I’m general these issues with karma rop and Houdini 19 not loading at all on Ubuntu 21.10 are caused by changes to libraries included in the build?
User Avatar
Member
248 posts
Joined: June 2016
Offline
chrism
sudo apt install libopengl0 freeglut3 freeglut3-dev
Cool, now Karma is working in the viewport, I had to reassign materials but they are working
Edited by GCharb - Nov. 5, 2021 12:46:35

Attachments:
Screenshot from 2021-11-05 12-34-08.png (1.4 MB)

User Avatar
Member
232 posts
Joined: March 2009
Offline
chrism
sudo apt-get install --reinstall libxcb-xinerama0

Wow... Running this really made a difference!!! Not a crash so far! Any other tricks and libraries to reinstall to make it more stable proactively?

I find that I have to run 'source houdini_setup' and 'export LD_PRELOAD="/lib/x86_64-linux-gnu/libc_malloc_debug.so.0"' from the command line every time I run 'houdini'. Even after it crashes every time.

TY!
User Avatar
Member
232 posts
Joined: March 2009
Offline
GCharb
chrism
sudo apt install libopengl0 freeglut3 freeglut3-dev
Cool, now Karma is working in the viewport, I had to reassign materials but they are working
Yes, worked magic for me as well.
User Avatar
Member
918 posts
Joined: March 2014
Offline
chrism
Apparently some users had luck installing some linux missing libraries:
sudo apt install libopengl0 freeglut3 freeglut3-dev

Thanks Chris,

In my quest to get H19 Karma running I've checked the system requirements for Linux. Does it make sense to include them here: https://www.sidefx.com/Support/system-requirements/ [www.sidefx.com]

Thanks again and happy weekend
User Avatar
Member
6 posts
Joined: Nov. 2016
Offline
I got 18.5 and 19 to start, but it's a bit of a roll of the dice. At least 50% of the time it will result in a crash. I'll post some of the crash reports tomorrow.

So, I have all the libs mentioned above installed on a fresh 21.10. as mention it does work, but it takes a few tries sometime to get houdini launched. Simply launching it from the terminal. I get various type of crash ranging from no message at all to this :

------------------------------------------------------------
Traceback from 8222 ThreadId=0x7fd9553f7cc0
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo_t*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo_t*, void*) <libHoudiniUT.so>
__sigaction <libc.so.6>
free (tcache.h:406)
_nv014glcore <libnvidia-glcore.so.460.91.03>
_nv014glcore <libnvidia-glcore.so.460.91.03>
<libGLX_nvidia.so.0>
vk_icdNegotiateLoaderICDInterfaceVersion <libGLX_nvidia.so.0>
------------------------------------------------------------

and this:

------------------------------------------------------------
houdini-bin: pthread_mutex_lock.c:90: ___pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.
8576: (sent by pid 8576)
8513: Fatal error: Segmentation fault (sent by pid 908)


Traceback from 8576 ThreadId=0x7fd18c690cc0
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo_t*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo_t*, void*) <libHoudiniUT.so>
__sigaction <libc.so.6>
pthread_kill <libc.so.6>
raise <libc.so.6>
abort <libc.so.6>
<libc.so.6>
__assert_fail <libc.so.6>
pthread_mutex_lock <libc.so.6>
je_tcache_bin_flush_small (mutex.h:77)
free (tcache.h:402)
_nv014glcore <libnvidia-glcore.so.460.91.03>
_nv014glcore <libnvidia-glcore.so.460.91.03>
<libGLX_nvidia.so.0>
vk_icdNegotiateLoaderICDInterfaceVersion <libGLX_nvidia.so.0>
Edited by lrntbrt - Nov. 6, 2021 18:33:58
User Avatar
Member
6 posts
Joined: Nov. 2016
Offline
19.0.430 daily build is no longer crashing for me like the production build. Redshift 3.0.59 works fine as well.

But 18.5 remains an issue, production or latest daily.
User Avatar
Member
34 posts
Joined: Sept. 2014
Offline
chrism
Apparently some users had luck installing some linux missing libraries:
sudo apt install libopengl0 freeglut3 freeglut3-dev

Using Pop_os 21.04, this fixed houdini 19.0.383 not showing anything in the sceneview and crashing when switching to a render engine such as karma in a solaris view.
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
I have the same issue but on Fedora 35.
None of suggested things hepled. Any idea?
User Avatar
Member
19 posts
Joined: Aug. 2014
Offline
Mirko Jankovic
I have the same issue but on Fedora 35.
None of suggested things hepled. Any idea?

What error are you getting?
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
munmap_chunk(): invalid pointer
Aborted (core dumped)
On .383

and with daily build 450
Segmentation fault (core dumped)

Any ideas?

Fedora 35 here
User Avatar
Member
232 posts
Joined: March 2009
Offline
Run

export LD_PRELOAD="/lib/x86_64-linux-gnu/libc_malloc_debug.so.0"

Before you run Houdini from the command line.

You might still get segmentation fault after so just keep typing houdini and it should load on 2nd or 3rd attempt.

I’m actually quite disappointed that sidefx havent fixed this yet. Assuming there’s a good reason. Maybe complexity.
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
Still no luck:

ERROR: ld.so: object '/lib/x86_64-linux-gnu/libc_malloc_debug.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/lib/x86_64-linux-gnu/libc_malloc_debug.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
User Avatar
Member
19 posts
Joined: Aug. 2014
Offline
Mirko Jankovic
Still no luck:

ERROR: ld.so: object '/lib/x86_64-linux-gnu/libc_malloc_debug.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/lib/x86_64-linux-gnu/libc_malloc_debug.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

It might be that the libc_malloc_debug.so.0 file is located elsewhere on Fedora. I'd check check if it actually exits at that location. If it doesn't, try to search for it in your system.
Edited by kubo-von - Nov. 26, 2021 18:17:36
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
export LD_PRELOAD="/usr/lib64/libc_malloc_debug.so.0"

Found it's the location it preloads without error but now different error:

56935: Fatal error: Segmentation fault (sent by pid 1107311872)
Crash log saved to /tmp/houdini_temp/crash.cgoven_356935_log.txt
sh: line 1: xmessage: command not found


And in that log file:
Crash report from cgoven; Unknown App Version 19.0.383
Uptime 0 seconds
Sat Nov 27 07:38:10 2021
Caught signal 11

Traceback from 356935 ThreadId=0x7f4656ff9e00
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo_t*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo_t*, void*) <libHoudiniUT.so>
__GI___sigaction <libc.so.6>
free <libjemalloc.so.1>
_nv014glcore <libnvidia-glcore.so.470.86>
_nv014glcore <libnvidia-glcore.so.470.86>
<libGLX_nvidia.so.0>
vk_icdNegotiateLoaderICDInterfaceVersion <libGLX_nvidia.so.0>
User Avatar
Member
930 posts
Joined: April 2008
Offline
I was getting the same error until I exported the correct path, now at least it started.

Thanks!
Edited by mzigaib - Nov. 28, 2021 10:38:06
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
What correct path? I still have same problem on fedora. although just tested on rocky linux and it works fine...
User Avatar
Member
930 posts
Joined: April 2008
Offline
I just did like you described:

export LD_PRELOAD="/usr/lib64/libc_malloc_debug.so.0"

And it worked
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
86 posts
Joined: Aug. 2015
Offline
ah I see. no luck here...
User Avatar
Member
930 posts
Joined: April 2008
Offline
Actually I got a lot of fatal errors when I try to launch:

12441: Fatal error: Segmentation fault (sent by pid 1433951232)

This is what says that log:

Crash report from user; Unknown App Version 19.0.451
Uptime 0 seconds
Sun Nov 28 15:51:49 2021
Caught signal 11

Traceback from 12441 ThreadId=0x7ff2a9f16dc0
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler::operator()(int, siginfo_t*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo_t*, void*) <libHoudiniUT.so>
__GI___sigaction <libc.so.6>
free <libjemalloc.so.1>
_nv014glcore <libnvidia-glcore.so.495.44>
_nv014glcore <libnvidia-glcore.so.495.44>
<libGLX_nvidia.so.0>
vk_icdNegotiateLoaderICDInterfaceVersion <libGLX_nvidia.so.0>


But I type Houdini again until it works, weird but it works.

I am hoping that since Fedora 35 is relatively new some future updates can solve the problem?
Edited by mzigaib - Nov. 28, 2021 18:20:38
https://vimeo.com/user2163076 [vimeo.com]
  • Quick Links