In Part 3, we will begin rigging the Left Arm. The arm will have both Forward and Inverse Kinematics, the ability to twist both the upper and lower arm as well as 'space switching' for the wrist.

コメント

  • harryabreu 4 年, 2 ヶ月 前  | 

    Thank you again Mr Goldfarb.

  • mwessels 4 年, 2 ヶ月 前  | 

    Thanks for this series. Is there any way I can subscribe to this series or the learning section to be alerted when new training is posted? That would be very helpful to stay current with what you guys are doing. Thanks again.

  • traileverse 4 年, 2 ヶ月 前  | 

    Great series, thanks for these, however, why videos take so long to come out though? Maybe I'm just impatient (-:

    • goldfarb 4 年, 2 ヶ月 前  | 

      we've just had lots of material to get through in editing...but we're working hard to get them out as quick as we can :)

  • IceBar0n 4 年, 2 ヶ月 前  | 

    Thank you very much !! your work is very important for us !!!

  • Danil Shaposhnikov 4 年, 2 ヶ月 前  | 

    Very helpfull! But i can`t mirroring this rig. Bones take negative scale when i mirror them (-1,-1,-1). And it turn the normals of skinned geo out. I can`t fix it.

  • jon3de 4 年, 2 ヶ月 前  | 

    hey thank you for these series!! This tutorials helps us a lot with our current character project. Do you know roughly when the next videos gets released for the hands? :)

  • seifdune 4 年, 1 ヶ月 前  | 

    Fk/ik switching making the arm to flip i don't know what is a problem, trying to rig arm without changing the bones rotations to be positive(by rotating z-axis 180) it work without fliping but give negative value when rotating foward. How can i solve this problem?

    • jon3de 4 年 前  | 

      I have the same problem. I also couldn´t fix it for now.

      • jon3de 4 年 前  | 

        You can try to recreate the blend constraints for your L_arm_bone Ctrls. Make sure to use simple mode and keepPosition: after . It seems to work here.

      • jon3de 4 年 前  | 

        It seems I was a little bit to fast. Switching the blend in the inverseKin Chops Network still causes my second Arm Bone to turn around 180°

    • jon3de 4 年 前  | 

      ...ok I fixed it now like that. If you look in your bone in the "bone" tab there is a rest angle value. I set this to 0° and it helped to fix the rotation issue.

  • jon3de 4 年 前  | 

    On 34:34 I recognized that you accidently droped the "offset" on "L_Arm_bone1" on a line and now it uses the simpleblend node for the BindPose input instead of the "getworldspace" node. Is this bad? Im struggeling a little bit with twisting bones and while searching for an error I saw that.

    I assume the BindPose should be connected to the getworldspace?

  • dddmod___ 3 年, 8 ヶ月 前  | 

    Hello! How can I snap my bones not to the model but to the grid? http://take.ms/bvc5q

  • goldfarb 3 年, 8 ヶ月 前  | 

    @dddmod__
    you can turn on Grid Snapping on the left side of the viewport
    http://www.sidefx.com/docs/houdini/basics/ui.html

  • dddmod___ 3 年, 8 ヶ月 前  | 

    Thank you very much!

  • dddmod___ 3 年, 8 ヶ月 前  | 

    When I add the IK my bones hand is jumping. Do I do something wrong? http://take.ms/E685M

    • goldfarb 3 年, 8 ヶ月 前  | 

      post your file to the forums and I can take a look

      • dddmod___ 3 年, 7 ヶ月 前  | 

        Michael, what do you think about IK? Why do the bones do not hold a position while adding inverse kinematics?

        • goldfarb 3 年, 7 ヶ月 前  | 

          I'd need to see the file - can you post to the forum - it's much easier to have a conversation there

          • dddmod___ 3 年, 7 ヶ月 前  | 

            Of course. I have already attached a similar file just below but I can resend it again
            Here's how my IK works http://take.ms/YCvPm
            And here's the Houdini file http://take.ms/07n8F

            • goldfarb 3 年, 7 ヶ月 前  | 

              your upper and lower arm bones are not straight - the IK solver doesn't like this.

              • dddmod___ 3 年, 7 ヶ月 前  | 

                How is this problem solved?

                • goldfarb 3 年, 7 ヶ月 前  | 

                  the bones should be straight - and you'll want to make the IK between chain_bone9 and chain_bone10 only

                  • dddmod___ 3 年, 7 ヶ月 前  | 

                    I don't really understand what "straight" means, but I still think over it.
                    What am I doing wrong here? :-) http://take.ms/9Dura

                    • goldfarb 3 年, 7 ヶ月 前  | 

                      I mean straight like in the autorig file you sent

                      I don't know what you are trying to do in that video


                      can you please create a thread in the Forums?
                      https://www.sidefx.com/forum/4/

                      this comment thread is for discussion of the left-arm video, not general rigging help.

                      • dddmod___ 3 年, 7 ヶ月 前  | 

                        I can create a thread but I didn't want to create new themes for every little thing.
                        There I was just trying to repeat the operation "simple blend" following your lesson. So I recorded a piece of your video to make it clear what I'm doing.

                        • goldfarb 3 年, 7 ヶ月 前  | 

                          make one thread and you can use it for all if your questions :)

                          • dddmod___ 3 年, 7 ヶ月 前  | 

                            Оkay :)

  • enixan8 3 年, 8 ヶ月 前  | 

    I didn't notice your answer. I'll post the file later. Could you take a look at this video? - http://take.ms/F8wBEf When I do the Autorig and click on the bone generation I don't see bones. And also when I delete unnecessary elements in the process of Autorig, I get an error when I generate bones. Am I doing something wrong?

    • goldfarb 3 年, 8 ヶ月 前  | 

      In the Create New Autorig Asset dialog
      in the Geometry Capture section there is an option called "Capture | Deform by Default"
      this is OFF by default because, depending on the resolution of your mesh the capture step could take many minutes - and I didn't want people to think that Houdini had frozen, now that there is a progress bar I'm thinking of changing this to be ON by default...
      anyway - because this is OFF - the capture step needs to be done manually:
      right-click on the asset and select "Allow Editing of Contents"
      enter the asset and then enter the geo_skin node
      look for the deform node - should be the last in the network
      turn of it's display flag
      select the stash node just above it
      click "stash input"
      this will take a min to cook
      now you can go back up to the /obj level and right click you asset and select "Save Node Type", then "Match Current Definition"
      your character should now deform when you animate it

      "...when I delete unnecessary elements..."
      um - don't delete anything - all the elements are necessary.

      you should watch the masterclass on the Autorigs - https://www.sidefx.com/tutorials/autorigging-masterclass/

      • goldfarb 3 年, 8 ヶ月 前  | 

        oh and the bone display is off by default - on the Root tab turn on Bone Display All

  • dddmod___ 3 年, 8 ヶ月 前  | 

    Here's the file I promised to send http://take.ms/ta6eC

    Here I try to follow all your instructions - http://take.ms/2cNT5
    but the bones are still not visible and I do not have a seizure of weights.

    Where do I err?

    And thanks a lot of course for your answers!

    • goldfarb 3 年, 8 ヶ月 前  | 

      when you add a mesh to the Autorigs it automatically turns the display of the original object OFF - but the Autorig tools do not work with multiple objects as the mesh - you can very easily combine them all and use the result - that is why your mesh disappeared.

      it is hard to tell but it looks like you were trying to paint the capture weights using the middle mouse button - it looked like the capture region selection was changing as you painted.

      The Capture Layer Paint tool WILL NOT paint mirrored capture weights in the way you think it will.
      with Symmetry ON you will be painting that same weight on both sides of the mesh - NOT the corresponding weights on the other side of the mesh.

      • dddmod___ 3 年, 8 ヶ月 前  | 

        Thank you very much for the answers! But I still didn't understand how to draw the symmetric weights? The Houdini has the ability to copy the weight from the left bones to the right? Or is it necessary to draw it manually?

  • dddmod___ 3 年, 8 ヶ月 前  | 

    I forgot to add mesh to the rigbing. That's what I'm doin - http://take.ms/VDxQF
    How can I add the Autorig and capture weights to several individual objects at once? When I select all objects at once then I disappear the whole model

  • dddmod___ 3 年, 8 ヶ月 前  | 

    I also experienced a problem with weights. When I paint the weight of the brush does not change anything http://take.ms/vpJJJv
    What am I doing wrong?

  • dddmod___ 3 年, 8 ヶ月 前  | 

    How to draw symmetric weights for different bones? http://take.ms/hqIRR

    • goldfarb 3 年, 8 ヶ月 前  | 

      use the 'mirror capture weight tool'
      capture layer paint - DOES NOT paint mirrored weights

      • dddmod___ 3 年, 8 ヶ月 前  | 

        That's the thing that I don't understand how it works http://take.ms/IPG1D

  • dddmod___ 3 年, 8 ヶ月 前  | 

    Maybe somewhere there is a video about how works mirror capture weight tool ?

    • goldfarb 3 年, 8 ヶ月 前  | 

      there will be soon.

      • dddmod___ 3 年, 8 ヶ月 前  | 

        Look forward :-)

  • dddmod___ 3 年, 8 ヶ月 前  | 

    How can I manage the hierarchy of bones? The autorig creates not very convenient system of hierarchy http://take.ms/AQ0mu
    It is much better when the parent bone is the pelvis, then the chest goes, and then the head and arms. It can be changed only with the help of nodes or it can be configured in the process of autorig?

    • goldfarb 3 年, 7 ヶ月 前  | 

      the autorig creates a specific rig - if this rig isn't designed the way you want then you'll have to build your rig from scratch

  • dddmod___ 3 年, 8 ヶ月 前  | 

    When I do the autorig I get not correct symmetry http://take.ms/YWUQRE
    What could be the reason?

    • goldfarb 3 年, 7 ヶ月 前  | 

      to rotate the feet, use the foot root guide - it's the one that sits on the groundplane just behind the heel of you character, don't use the ankle rotation.

  • dddmod___ 3 年, 8 ヶ月 前  | 

    What do I need to do to enter the weights drawing mode? I thought that it is enough to allocate the nodu "capturecorrect" But it doesn't work - http://take.ms/8MFkD
    It's all so hard. How can I do that?

    • goldfarb 3 年, 7 ヶ月 前  | 

      'Capture Layer Paint' and 'Edit Capture Weights' are tool that are invoked from the Object context
      make sure that the Deform SOP is the display SOP
      then go UP to the Object level and use the shelf tools or TAB > to use these tools

  • dddmod___ 3 年, 7 ヶ月 前  | 

    Help me please understand how to copy weights. I'm used to 3DS Max where you can copy the symmetric weights in one click. In Houdini, I can't understand the logic. That's how I try to do it but everything is useless http://take.ms/yA7Js Maybe it's not difficult for you to record a small video screen from your monitor to see how do you do it?

    • goldfarb 3 年, 7 ヶ月 前  | 

      I can't attach anything here
      I've started a Forum post and added a quick video:
      https://www.sidefx.com/forum/topic/59127

      • dddmod___ 3 年, 7 ヶ月 前  | 

        Thanks a lot Michael!

      • dddmod___ 3 年, 7 ヶ月 前  | 

        I can't send a message there, I'll write here. Сan you take a look here, Michael? http://take.ms/YmV1U
        What am I missing? While recording the video it does not copy the size to the center, here I did but it still doesn't work http://take.ms/NElki

        • goldfarb 3 年, 7 ヶ月 前  | 

          your group is called "group_www"
          but the capture mirror is expecting "www"

          • dddmod___ 3 年, 7 ヶ月 前  | 

            I would not like to bother you with further questions but I have to understand why my mirror does not work. Here I do everything the same as you do on your video http://take.ms/E4VDi In the second example with a cylinder the mirror works even without creation of a group, but with this turtle does not want to work. I need to understand the reason. I can give a scene http://take.ms/LIQ5k

            • goldfarb 3 年, 7 ヶ月 前  | 

              your capturelayerpaint1 has a "!" icon - this is a warning and you should always pay close attention to warnings - if you middle mouse on the capturelayerpaint1 node you'll see the popup says:
              "Capture region "../../bone2/cregion"
              is no longer valid. It may have been deleted
              or the Skeleton Root Path is incorrect.
              Please re-capture or use CaptureCorrect if it was deleted. "

              so at some point you had a bone2 and painted on it - but now that bone is gone - it's not a big deal - but it is interfering with the mirror tool
              appending a capturecorrect (default settings) SOP right after the capturelayerpaint1 will correct this
              now the capturemirror2 will work.

              • dddmod___ 3 年, 7 ヶ月 前  | 

                Thank you! Looks like it works. I'll check again.
                I was looking for a copy mirror pose and found your answer on forum https://www.sidefx.com/forum/topic/45527/
                Since then has not appeared any tool for mirror copying poses without scripts?

                • goldfarb 3 年, 7 ヶ月 前  | 

                  no, something like this would need to be scripted - either as part of the rig or as a shelf tool etc.
                  I didn't add one in this tutorial series because I wanted to keep the time down.

                  • dddmod___ 3 年, 7 ヶ月 前  | 

                    Hopefully some button will appear in Houdini for mirror poses :-)

  • dddmod___ 3 年, 7 ヶ月 前  | 

    Here is one more example http://take.ms/ynvrZ

  • dddmod___ 3 年, 7 ヶ月 前  | 

    Michael, why the tool Mirror has a distorted center? http://take.ms/7AWQM

    • goldfarb 3 年, 7 ヶ月 前  | 

      it's hard to say without seeing the file

      • dddmod___ 3 年, 7 ヶ月 前  | 

        http://take.ms/jwdNc

        • goldfarb 3 年, 7 ヶ月 前  | 

          in your AUTORIG
          chain_bone3 and basicface_Jaw_jawroot have rotations in y and z - this is causing them to be mis-aligned with the YZ plane - so when you're mirroring basicface_Jaw_jawbone2 and basicface_Jaw_jawbone3 they look wrong.

          • dddmod___ 3 年, 7 ヶ月 前  | 

            How to align a bone or Null in the center of world coordinates with the correct rotation?

            • goldfarb 3 年, 7 ヶ月 前  | 

              just rotate them/set their values directly

  • lcatalo 3 年, 6 ヶ月 前  | 

    Hi all,

    First of all, great videos and thanks for this series.

    I've got a issue with the "blend constraint" inside the FK constraint (31:38 minute of part 3) and I hope you can help me to check what's happening. I get this behavior in a new scene with only a two bones chain.
    First create the two bones chain. Then create two controllers to move the respective bone. Create a "Blend Constraint" for each bone to get the FK working. And it does. Works like a charm. When I create a "IK With Twist Affector" and "Add Kinematics" to that same bone chain, the IK doesn't work because the blend constraints that I got for the FK, as expected. The idea, like said in the video, is to create inside the constraint a "Blend Constraint" node to use as a switch and get the world space or world space with offset (IK or FK action). My problem is that when I create the "Blend Constraint" node I still cannot move the IK and I lose the FK as well. The'res anyone who got the same problem? I've check the video numerous times to see if I miss anything but I can't figure it out.

    Thanks for the help..

    • lcatalo 3 年, 6 ヶ月 前  | 

      Forgot to tell you that I'm using the Houdini Core 17.0.352...

    • islanimations 3 年, 6 ヶ月 前  | 

      Yes I am getting the same problem. I tried to do it again and again but couldn't solve it.
      Please help me.

      • goldfarb 3 年, 6 ヶ月 前  | 

        we found an issue with constraints just before the Holidays and it was fixed around Dec10 - try the latest build of Houdini - at the moment that is Houdini 17.0.451

    • goldfarb 3 年, 6 ヶ月 前  | 

      we found an issue with constraints just before the Holidays and it was fixed around Dec10 - try the latest build of Houdini - at the moment that is Houdini 17.0.451

      • lcatalo 3 年, 6 ヶ月 前  | 

        Thank you goldfarb =)

  • bharti21 3 年, 6 ヶ月 前  | 

    Hi,
    My IK controls are not working at all even after modifying the constraints in L_arm_bone1 and L_arm_bone2.
    Please guide me.

    • goldfarb 3 年, 6 ヶ月 前  | 

      we found an issue with constraints just before the Holidays and it was fixed around Dec10 - try the latest build of Houdini - at the moment that is Houdini 17.0.451

  • islanimations 3 年, 6 ヶ月 前  | 

    Thank you goldfarb!
    I am using Houdini Apprentice 17.0.352 . Could you please tell me from where I can get this Houdini 17.0.451 because on the download page (https://www.sidefx.com/download/) only houdini 17.0.416 is available.

  • lcatalo 3 年, 5 ヶ月 前  | 

    islanimations,

    You can find the daily builds here - https://www.sidefx.com/download/daily-builds/#category-devel

    The link is in the bottom of the download page where you have find that.

  • islanimations 3 年, 5 ヶ月 前  | 

    Thank you so much Goldfarb.
    Now my IK is working but not in the same as it is working in the tutorial. My character is in T-pose. Should I use A-pose for rigging?
    Kindly guide me.

  • DanielLeask 3 年, 3 ヶ月 前  | 

    Hi there I'm having a little trouble with my IK/FK switch, I did everything that the tutorial told me to do, but every time I switch from IK to FK controls the L-Arm seems to do a little movement like it's bracing itself for the switch. What I do in this case, as I can think its going to affect my animation if i do?

  • LittleNinja 3 年, 1 ヶ月 前  | 

    Using 17.5 and I'm experimenting the blend constraint problem when adding the IK with twist to the arm that had blend constraint, any ideas?

  • azeroc 3 年, 1 ヶ月 前  | 

    I can also confirm that the bug related to the blend constraints, after adding the IK, is still there. Basically after you blend constraint between getworldspace and offset and set the blend to 0, the IK goal is affecting just the lowerarm (arm_bone_2 in the video). I am on the latest production build Houdini 17.5.229.

    • azeroc 3 年, 1 ヶ月 前  | 

      Ok, found the solution. You need to add two blends for the constraintblend node. First blend 0, second 1 - FK is active, First blend 1, second 0 - IK moves. This needs to be for both arm bones.

      • DanielLeask 3 年, 1 ヶ月 前  | 

        Can you be more clearer, I add another blend into the constraints blend and done what you have suggested however I want to know in detail what you mean otherwise what you are suggesting is put two blends into the blend constraints first blend 0 second 1 in bone 1 on left arm and vice versa on bone 2 i thought it doesn't make sense when I read it and it doesn't do anything, it just makes my IK not work properly, which I thought as much.

        • azeroc 3 年, 1 ヶ月 前  | 

          What I am suggesting is what Michael Goldfarb does at the end of the video, instead of adding just one blend that is used for controlling the IK/FK switch, he adds two blends for each bone. It is explained at the end of the video. But, having said that, in my situation it didn't work, it only worked on a test scene where the bones were made to simulate the arm but they weren't put in an A pose like it is my character, they were perfectly aligned on the center line so everything worked fine in that test. So I had to ditch IK/FK switch because it wasn't working at all for my character and rely only on IK.

        • nolan515 3 年, 1 ヶ月 前  | 

          I'm on 17.5.229 and I think you sort of have to do a combo solution to make it work:
          --Step one (found by lcatalo) is that you do everything in the tutorial, but once you set up the blend constraints, select all your nodes, delete them, then hit undo. Then the IK works with no issue. But to get FK to work, you need to do Step Two.
          --Step Two (found by azeroc): Add another blend to the blend constraint in each bone. "First blend 0, second 1 - FK is active, First blend 1, second 0 - IK moves."

          This works for me. I'm able to blend between IK/FK after doing this.

          • cmaudhuit 3 年 前  | 

            I am working on 17.5.229, many thanks to you guys for that workaround.
            As weird as it is, it does work perfectly for me as well.

            • scarything 3 年 前  | 

              haha, why does this work. thanks though!

  • Vesse 3 年 前  | 

    Hi.

    Great series. I am really enjoy rigging in Houdini. I have encountered a problem though. Everything works fine, except the FK/IK blend. For some reason the forearm bone rotates a bit between 0 and 1. What could be the issue?

    The issue was worst the first time I followed along. Then the forearm rotated 180 degrees between 0 and 1. I changed the forearm bone control's pivot rotate to 180 and that fixed that problem, but now it flips 45 degrees one direction an then back. So basically, everything is fine, unless I have to animate and show the forearm in transition from IK to FK or vice versa.

    Thank you in advance.

    • Vesse 3 年 前  | 

      Update:
      I found out that the problem was caused by driving the IK blend in the KIN_Chops with the FK/IK Blend parameter. When I deleted the channel, the forearm did not rotate when I switched from IK to FK and back. It seems that the rest of the functionalities are intact.

      This worked on version 17.5.229

      • Vesse 2 年, 11 ヶ月 前  | 

        Update [version 17.5.229]:

        Went through it with another character and delved deeper, to find a batter solution.

        I found a way to get a problem free solution by creating the IK constraint for the arm first and then the FK ctrl constraints.
        Then I used the IK/FK switch parameter to drive the offset node blend parameter in the constraints network.

        The arm solutions works without issues.

        Cheers!

  • Simon van den Broek 2 年, 6 ヶ月 前  | 

    Hey, first of all I want to thank you for producing these tutorials, I have a question though.

    I never did any rigging before so I am a complete noob I would like to ask something though.

    from practising weight lifting, I believe the scalpula always rotates with the clavicle. why did you choose to use 3 bones and proceed to rotate both the clavicle and scalpula from this center position? doesn't this technically dislocate the clavicle from the sternum?

    wouldn't it be better to rotate the entire shoulder girdle from the clavicle position?

    kind regards,

    Simon

    • goldfarb 2 年, 6 ヶ月 前  | 

      hi
      you could do that if you wanted - this tutorial was based on another that was requested by a number of people, so I tried to follow it closely :)

  • FranciscoBravo 2 年, 1 ヶ月 前  | 

    Hi, this is the third or fourth time I followed this great tutorial, and every time I create the blend from IK to FK my L_Arm_bone 2 rotates a 180 degrees (and it seems to be a common issue) the way I found to get rid of this problem is by changing the REST ANGLE of both bones ( L_Arm_bone1 and L_Arm_bone2) to 0 in X, Y and Z.
    I am not sure if this would bring me future problems down the line, but it works every time, so I hope this tip helps you.

  • burakumincgi 2 年, 1 ヶ月 前  | 

    any idea why the "FK control" script is not picking up the name of the selected node? H18.460

    • burakumincgi 2 年, 1 ヶ月 前  | 

      never mind, found what was missing in the code in the next video

Please log in to leave a comment.