Houdini 21.0 ノード Copernicusノード

Bake Geometry Textures Copernicus node

低解像度メッシュと高解像度メッシュ間のベイク処理をインタラクティブな速度で実行してテクスチャを生成します。

On this page
Since 21.0

これは、ジオメトリデータをメッシュ間で転送するベイクノードです。 このノードは、高解像度サーフェスの細かな特徴部を、低解像度サーフェス上のテクスチャマップとして表現します。

Bake Geometry Texturesノードは、ほぼリアルタイムで動作するベイクノードです。 パラメータまたはマップのベイクをすぐにプレビューすることができます。 また、Copernicusネットワーク内でベイク済みのマップやAOVに即時アクセスすることができるので、シェーダやマテリアルの構築に向けたさらなる処理や操作が可能です。

例えば、このノードを使用することで、ゲーム向けの低解像度メッシュ上で高精細なルックを偽装することができます。

基本的なワークフロー

  1. Geometry(SOP)ネットワーク内で、ベイクに使用するメッシュを準備します。 使用可能なメッシュタイプについてはメッシュタイプを、最適な結果を得るためのメッシュの準備方法についてはベイクの良い事例を参照ください。

  2. Copernicus(COP)ネットワーク内で、 Bake Setup ノードを作成します。 これは、ベイク処理に必要な複数のノードを生成します。

  3. その3つのSOP Import COP(lowhighcage)で、各 SOP Path に、SOPコンテキストで準備したメッシュのパスを設定します。 このcageメッシュは任意です。

  4. cageメッシュを使用する場合、Bake Geometry Textures COPの Tracing ModeCage Mesh に設定します。

  5. Bake Geometry Textures COPのディスプレイフラグをオンにします。 しばらく待つと、ベイクされたマップがビューポートに表示されます。 このノードの設定を変更して、ベイク結果を調整します。

  6. ベイクするマップは、Bake Geometry Textures COPの Texture Maps タブにあるトグルで選択します。 このノードの右下の出力名をクリックすると、表示するマップを選択することができます。 このノードは、トグルがオンになっているマップのみをベイクして表示します。

  7. ベイク済みマップを低解像度メッシュ上でプレビューするために、Preview Material COPを追加して、以下の操作を行ないます:

    1. low SOP Import COPのgeometry出力をPreview Material COPのgeo入力に接続します。

    2. プレビューしたいマップをPreview Material COPのそれに呼応する入力に接続します。 通常だと、接線空間の法線マップをnormal入力に、デバッグ用途で他のマップをbasecolor入力に接続すると良いでしょう。

  8. 選択したマップをエクスポートするために、ROP Image Output COPを作成して、以下の操作を行ないます:

    1. Bake Geometry Textures COPのAll Outputs Port(右上のブロック)をROP Image Output COPの入力に接続します。

    2. ROP Image Output COPの File Layout タブにある Add AOVs from Input ボタンをクリックします。 これによって、Bake Geometry Textures COPで有効にしているマップが自動入力されます。

    3. ROP Image Output COPの Output File のファイルパスの一部に<LAYER>(表示されている通り正確に)を追加します。 この文字列は、エクスポート時に自動的にマップ名に置換され、 Render to Disk ボタンをクリックすると、複数のマップを一度にエクスポートすることができます。

メッシュタイプ

ベイク処理に関係するメッシュタイプは3種類あります:

低解像度メッシュ

低解像度メッシュは、オフラインレンダリングまたはリアルタイムレンダリングに使用される最終メッシュです。 出力されたベイク済みマップはこのメッシュに適用されるので、このメッシュには、テクスチャ用に意図された最終UVレイアウトが必ずなければなりません。 低解像度メッシュには、ベイク処理前に最終法線(N)と最終接線(tangentu)が含まれていることを強く推奨します。 対象のレンダラーやゲームエンジンがインポート時またはランタイム時に三角分割を行なう場合、この低解像度メッシュもベイク処理前に三角分割しておくことを推奨します(詳細はベイクの良い事例を参照してください)。

高解像度メッシュ

高解像度メッシュは、ベイクされるマップに転送するジオメトリのディテールが用意されたソースメッシュです。 ベイク処理では、この高解像度メッシュの様々な種類の情報を、低解像度メッシュのテクスチャ空間にエンコードします。 何かしらの種類の法線マップをベイクする場合は、この高解像度メッシュに点法線/頂点法線(N)が含まれているべきですが、入力の高解像度メッシュに法線が存在しない場合、ベイク処理中に自動的に法線が生成されます。

ケージメッシュ

ケージメッシュは、レイトレーシングの起点と方向をより正確に制御するために使用可能なオプションのメッシュです。 ケージメッシュは、低解像度メッシュと同じトポロジを持ち、且つ、低解像度メッシュと高解像度メッシュの両方を完全に覆っている必要があります。 光線は、そのケージ表面から低解像度メッシュ表面上のトポロジ的に同じ位置に向けてトレースされます。 これによって予測率が高まり、ケージにUVを必要とせず、低解像度メッシュの法線関連で起こり得る問題も無視されます。

ケージメッシュがない場合、光線は、低解像度メッシュ表面からサーフェス法線に沿って双方向にトレースされます。 メッシュの色々な箇所に特徴スケールが異なる(つまり、類似性がない)、オクルージョン、凸性、凹性の顕著な差異が存在する場合、エッジ沿いや誤った表面との交点でサンプリングアーティファクトが発生する可能性があります。

ケージメッシュは、グローバルなパラメータに依存せず、領域的にトレースの挙動を制御することでこれらの問題を解決します。 ケージ頂点のオフセット距離と方向を低解像度メッシュの頂点から手動で調整することで、トレースの起点と方向を制御することができます。 ケージメッシュは、誤って低解像度サーフェスや高解像度サーフェスとの交差することなくメッシュの異なる部分を密接に覆うようにしてください。

ケージメッシュは、エッジに沿って完全に、または、部分的に分割される場合があります。 これは、低解像度メッシュと同じ頂点数で同じ頂点順になっている限り、頂点オフセット方向がより望ましいトレース方向になるからです。

ベイクの良い事例

  • このベイカーは足りない法線を低解像度メッシュ上に自動で追加することができますが、対象のレンダラーやゲームエンジンへ渡したい頂点法線は、ご自身で作成されることを推奨します。 これは、出力される接線空間法線マップが、ベイク時とレンダリング時の両方で低解像度メッシュの法線に大きく依存するためです。 ベイクされたテクスチャを低解像度メッシュに適用してレンダリングする際、そのテクスチャからの接線空間法線は、補間された低解像度メッシュ頂点法線を用いてワールド空間にトランスフォームされます。 テクスチャ法線をトランスフォームする際に使用する頂点法線は、テクスチャを最初にベイクした際に使用したものと同じにしてください。

  • 同様の理由から、ベイクに使用される接線がお望み通りになるように、ベイク前に低解像度メッシュにご自身で接線を追加することを推奨します。 MikkT接線空間を使用した場合、その接線計算は法線とUVに基づいて答えが1つに決まるので、アプリケーション間でほぼ整合性が取れることから、そうした方が低解像度メッシュの法線を使用するよりも融通が利きます。 PolyFrame SOPを使用することで、接線を作成することができます。

  • 低解像度メッシュの法線と接線は、頂点およびポイント上で正規化され、互いに直交しているようにしてください。

  • レンダラーやゲームエンジンでメッシュを使用する際にそのメッシュが三角分割される場合、ベイク前にメッシュを三角分割することを推奨します。 三角分割は頂点やポイントに保存されている法線や接線には影響を与えませんが、フェース全体にわたって補間される法線や接線は、フェースの三角分割の仕方に依存します。 Houdiniと対象アプリケーションが四角形やN角形を同じパターンで三角分割する保証はなく、この不整合が原因でフェース内(特に非平面フェース)に誤った接線空間法線が生成されてしまう可能性があります。

  • サンプルアーティファクトを回避するために、UVレイアウトにおいて十分なテクセル密度とUV島間の隙間を確保してください。

  • 低解像度メッシュにハードエッジ(スムージンググループ)が存在する場合、そのハードエッジの両側の頂点法線は連続していません。 この場合、ハードエッジに沿ってUVシームを設ける必要があります。 そうしないと、テクスチャ空間において、ハードエッジが多くのテクセルの中心を横切り、サブテクセル単位のトレース方向の不整合を引き起こし、最終のベイク処理でアーティファクトが発生する可能性があります。 UVシームを設けて、UV島間に十分な隙間を空けることで、法線が不連続なエッジの両側を離すことができ、これらのアーティファクトが解消されます。

  • 低解像度メッシュに可動コンポーネント(アニメーション可能、取り付け・取り外し可能なパーツなど)が多数含まれている場合、通常はこれらのコンポーネントを個別にベイク処理するべきです。 これによって、望ましくない落ち影や、他のパーツに溶接されたように見える現象を回避することができます。 コンポーネントを個別にベイクするには、低解像度メッシュ、高解像度メッシュ、ケージメッシュにpieceアトリビュートを追加します。 各コンポーネントのpieceアトリビュート値に固有の値を割り当て、同じコンポーネントが低解像度メッシュ、高解像度メッシュ、ケージメッシュ間で同じ値を共有するようにします。 Bake Geometry Textures COPの Match Pieces by Name を有効にして、 Piece Attribute を設定します。

  • メッシュが複雑で多様な特徴部を持つ場合は、カスタムケージメッシュを使用してベイク結果を改善することを検討してください。 詳細は、ケージメッシュを参照してください。

Note

Bake Geometry TexturesとKarma Texture Bakerは、同じトレーシングを使用しますが、根本的に異なります。 Bake Geometry Texturesは、曲率や接線法線などのジオメトリデータをベイクするインタラクティブなジオメトリベイカーです。 Karma Texture Bakerもこの類のベイクが可能ですが、主にライティング、マテリアル、シェーダのベイクに特化しており、それらのベイクタイプに使用するべきです。

パラメータ

Tracer

Tracer

使用するトレーサー。 これはハードウェアに基づいて利用可能なオプションのみを表示する自動メニューです。

Note

OptiXはNVIDIAハードウェアでのみ利用可能です。

Tracing Mode

このベイカーが使用するトレーシングモード。

Surface Normal

低解像度ジオメトリの法線から双方向に光線を放つ従来型のベイキング。 lowhighの入力が必要です。

Cage Mesh

ケージメッシュを使用してテクスチャマップの改善を図ります。 低解像度メッシュから高解像度メッシュへの光線の方向を決定することが困難な場合があります。

ケージメッシュを指定すると、光線は、そのケージメッシュ上の位置から低解像度メッシュ上のそれに呼応する位置に向けて送信されます。 ケージを使用したベイクでは、そのケージは、高解像度メッシュを完全に覆っていなければなりません。

Note

低解像度メッシュとケージメッシュは同じトポロジでなければなりません。 ケージメッシュは、 Tracing ModeCage Meshの場合にのみ使用されます。

Single Mesh (low)

単一メッシュのデータをベイクし、低解像度メッシュおよび高解像度メッシュには同じメッシュを使用します。 low入力が必要です。

UDIM Override

ベイクするUDIMを選択します。 これは、UDIMコンテキストオプションを上書きします。

Face Visibility Culling

ジオメトリに作用する二次光線の制御に使用されるメソッド。 これによって、ジオメトリ上の浮遊物を影を落とさずに低解像度マップに投影することができます。

No Culling

二次光線を無視しません。

Backface

ジオメトリの裏面に当たる二次光線を無視します。

Sample Multiplier

サンプル系パラメータ( Occlusion SamplesThickness Samples など)の乗数。 これは、全般的な品質スケールとして作用します。

例えば、 Sample Multiplier0.5Occlusion Samples256に設定すると、128サンプルでオクルージョンをベイクします。

Auto Generate Cage

Auto Generate Cage

低解像度メッシュの複製メッシュを生成します。 これは、cage入力不要で内部的にケージメッシュを自動生成します。

Cage Offset

複製メッシュが元の低解像度メッシュの法線から突き出る距離。

Soften Cage

Cage Offset を適用する前にジオメトリをファセット(角張)化します。 ソフトケージはファセット化されず、鋭いエッジでもシームレスな結果を保証しますが、法線が平均化されるため、投影エラーや歪んだディテールが生じる可能性があります。 (ファセット化された)非ソフトケージは、この投影の歪みを修正できますが、鋭いエッジでのディテールの捕捉を逃す可能性があります。

Tip

skew入力は、出力マップに投影エラー修正を適用することができます。 これは、ケージメッシュのコピーを作成して、フェースの面積で法線を平均化/ソフト化します。 最終的な光線方向は、このモノクロマップに基づいて、元の低解像度メッシュの法線とソフト化された法線の間でブレンドされます。

Setup

Normals

法線が欠落している低解像度ジオメトリに対するこのノードの挙動。 テクスチャベイクを機能させるには、低解像度メッシュに法線が必要です。

Error if Low Res Mesh Missing Normals

法線アトリビュートが存在しなかった場合、エラーを出します。

Warning if Low Res Mesh Missing Normals

法線アトリビュートが存在しなかった場合、警告を出しますが、内部的に頂点角度で重み付けされたポイント法線を追加します。

Silently Create Missing Normals

内部的に頂点角度で重み付けされたポイント法線を静かに追加します。

Tangents

法線アトリビュートが欠落している低解像度ジオメトリに対するこのノードの挙動。 テクスチャベイクを機能させるには、低解像度メッシュに接線アトリビュートが必要です。

Add MikkT Tangents if Needed

内部でPolyframe SOPを使用してMikkT接線を追加します。

Add Texture UV Tangents if Needed

内部でPolyframe SOPを使用してテクスチャUV接線を追加します。

Error if No Tangent Attributes Present

接線アトリビュートが欠落している場合、エラーを出します。

Advanced

UV Attribute

UV展開およびラスター化に使用するアトリビュート。 ここには、VertextアトリビュートまたはPointアトリビュートを指定することができます。

Flatten UV Z Values

一部のUV系ノードはデフォルトでfloat3値を出力しますが、これはUVモードでラスター化する時に予期しない結果を招く可能性があります。 このトグルは、float3 UVアトリビュートのZ成分を0に平坦化します。

Ray Bias

低解像度メッシュからシーンへ光線を送信する際、その光線の起点を低解像度メッシュ表面からオフセットさせる量。

このパラメータを使用することで、ケージメッシュを定義することなく、低解像度メッシュを法線方向に好きなようにオフセットさせることができます。

Match Pieces by Name

To...Do this

名前によるピースのマッチングを使用する

  1. (Nameノードなどを使用して)ピースアトリビュートを作成して、低解像度メッシュと高解像度メッシュの両方で互いに純粋にトレースさせたいプリミティブに同じ名前を割り当てます。

    例えば、キャラクタがバックパックを背負っている場合、低解像度メッシュと高解像度メッシュの両方のシャツプリミティブにshirt値を持つnameアトリビュートを設定し、低解像度メッシュと高解像度メッシュの両方のバックパックにbackpack値を持つnameアトリビュートを設定します。

  2. Match Pieces by Name を有効にして、 Piece Attribute に、それらのトレースセットの割り当てに使用したピースアトリビュートを設定します。 これは、デフォルトでnameになっています。

  3. (オプション) Include Pieces をスペース区切りの名前で更新します。 デフォルトでは、*が設定されており、すべてのセットが使用されます。 例えば、shirt backpackとすると、シャツとバックパックのトレースセットのみがベイクされます。

    トレースセットがたくさんある場合、一部を除外することができます。

Match Pieces by Name

オクルージョンや曲率などのレイトレーシング効果を計算する際、どのプリミティブを可視にするのかを制御することができます。 これは、低解像度ジオメトリと高解像度ジオメトリのプリミティブをマッチさせて、それらを独立領域に隔離します。 この独立領域を使用することで、交差エラーを回避することができます。 光線が現在のマッチ済みピースに属さないオブジェクトに当たった場合、そのオブジェクトは無視されます。 これによって再ベイクが行なわれ、ベイク結果が変更されます。

Note

このパラメータは内部的に Trace Sets として認識されます。

Piece Attribute

低解像度メッシュ、高解像度メッシュ、ケージメッシュ間で異なるピースを識別するために使用されるピースPrimitiveアトリビュート。

Include Pieces

常にベイクに含めるトレースセット。 これは、標準のHoudiniパターンマッチングを使用します。

Exclude Pieces

常にベイクから除外するトレースセット。 これは、 Include Pieces が収集された後に適用されます。 これは、標準のHoudiniパターンマッチングを使用します。

例えば、 Include Pieces*で、 Exclude Pieceshatの場合、 このベイカーは、hat以外のすべての利用可能なトレースセットをベイクします。

Enable UV Boundary Filling

Enable UV Boundary Filling

画像の空っぽの領域を、空っぽでない領域の境界の色で塗り潰します。 これは、UVシームの境界で暗いピクセル値を補正する後処理であり、テクスチャのmipmap処理時に良好な結果を生成することができます。

Note

この処理には時間がかかります。 反復処理を高速化するために、最終的なベイクでのみこの機能は有効にしてください。

Exterior

Edge Padding を超えたピクセルの設定に使用される方法。

Unchanged

ピクセルを変更しません。

Black

ピクセルを黒(0)に設定します。

Diffuse Fill

領域に対してSmooth Fill COPを実行して、ピクセル値を滑らかに補間します。

Edge Padding

ピクセル値をUV境界外側に直接コピーする距離(画像座標単位)。

Edge Offset

Edge Padding でUV境界外側へコピーする元の値を読み取る際、その元の値には既にUV境界外側の色が混入している可能性があります。 これは、指定した距離(画像座標単位)まで遡って外挿するクリーンな値を読み取ります。

Exclude Alpha from UV Fill

alphaマップのUV塗り潰しを無効にします。 alphaにUV塗り潰しを追加すると、完全に白色の出力となることが多いために、この機能があります。

Texture Maps

Tangent Space

Alignment

Normal Y Direction

接線空間法線(または丸め法線)AOVのY値の方向を決定します。

Tangent Normal

このマップタイプは、おそらくアセットやゲームエンジンでお馴染みのものです。 このカラーは法線方向を表現します。 接線空間の法線マップを用いることで、凸凹や凹みを擬似的に表現し、本来は実際のジオメトリで表現される表面構造を生成することが可能です。

Tangent Normal

Tangent Normal マップのベイクを有効にします。 無効の場合、normal出力はNullレイヤとなります。

Normal Space

レイヤが出力する法線タイプ。

法線を表現する自然な方法、および、ジオメトリにおける法線の表現方法は、符号付き法線を使用することです。 赤、緑、青のチャンネルには法線コンポーネントのX、Y、Zコンポーネントを格納することができ、その範囲は-1から1です。 しかし、歴史的にGPUや画像編集ソフトウェアはマイナスの値をサポートしていないため、通常では画像ファイル内の法線マップは、0から1の範囲の値を持つオフセット形式で保存されます。

Signed (-1 to 1)

符号付き法線:X、Y、Zコンポーネントが-1から1の範囲となります。

Offset (0 to 1)

オフセット法線:X、Y、Zコンポーネントが0から1の範囲となります。

Rounded Edge Normal

エッジが丸みを帯びたモデルは、モデリングしなくても、特殊なタイプの法線マップを使用して表現することができます。 ラウンドエッジ法線マップを用いることで、ジオメトリにエッジを足さなくても、表面間に滑らかな遷移を生成することができます。

Rounded Edge Normal

Rounded Edge Normal マップのベイクを有効にします。 無効の場合、edgenormal出力はNullレイヤとなります。

Rounded Normal Space

レイヤが出力する法線タイプ。

法線を表現する自然な方法、および、ジオメトリにおける法線の表現方法は、符号付き法線を使用することです。 赤、緑、青のチャンネルには法線コンポーネントのX、Y、Zコンポーネントを格納することができ、その範囲は-1から1です。 しかし、歴史的にGPUや画像編集ソフトウェアはマイナスの値をサポートしていないため、通常では画像ファイル内の法線マップは、0から1の範囲の値を持つオフセット形式で保存されます。

Signed (-1 to 1)

符号付き法線:X、Y、Zコンポーネントが-1から1の範囲となります。

Offset (0 to 1)

オフセット法線:X、Y、Zコンポーネントが0から1の範囲となります。

Rounded Samples

Rounded Edge Normal の計算に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Rounded Samples を上げることでノイズを減らすことができます。

Mode

ラウンドエッジ法線マップにおいて、凹エッジと凸エッジのどちらを取り込むのか決めます。

Radius

丸める法線の半径。

Cusp Angle

この閾値未満の角度を持つポリゴンは滑らかなサーフェスと見なされ、ラウンドエッジ法線マップには表示されません。

World Space

Alignment

World Space

ワールド空間の位置を、Y軸またはZ軸をUp軸とする左手系または右手系のどの空間で記録するかどうか。

World Normal

World Normal マップには、サーフェスの補間された法線(別名、 Phongシェーディング )が含まれます。 シェーディング法線は、リライティング用途でよく使用されますが、ノイズを生成する可能性があります。

World Normal

World Normal マップのベイクを有効にします。 無効の場合、worldnormal出力はNullレイヤとなります。

World Normal Space

法線マップの表現方法。

Signed (-1 to 1)

符号付き法線:X、Y、Zコンポーネントが-1から1の範囲となります。

Offset (0 to 1)

オフセット法線:X、Y、Zコンポーネントが0から1の範囲となります。

Position

ワールド座標値をレイヤのRGBコンポーネントにベイクします。 グラデーションは、オブジェクトエレメントがワールド原点からどの程度離れているかを視覚的に表現します。 例えば、このマップを使用して、オブジェクトの位置に依存する塵や風化の効果を作成することができます。

Position

Position マップのベイクを有効にします。 無効の場合、position出力はNullレイヤとなります。

Position Space

位置マップの表現方法。

Absolute ( Use Actual Position Values )

位置は正規化されず、オブジェクトサイズやワールド座標に依存します。

Relative ( Use Position Within Bounding Box)

位置は境界ボックスを基準に正規化されます。

Bounding Box

Position を格納する際、ここには、その位置の表現方法を指定します。

Fit to Bounding Box

シェーディング位置は、低解像度メッシュの境界ボックスにフィットされます。

Fit to Uniform Box (No Stretching)

シェーディング位置は、低解像度メッシュの均一な境界ボックスにフィットされます。 このモードでは、その境界ボックスの3軸すべてが同じ長さになります。

Geometry

Ambient Occlusion

オクルージョンマップは、3Dモデルが受ける環境光の量を表現します。 アンビエントオクルージョンとは、均一に照明された部屋の中にオブジェクトを置いた時に得られる効果です。 角や露出の少ない領域は光量が少なく、暗く見えます。 オクルージョンは、現実味を大幅に向上させるため、最も重要なマップタイプの一つです。 ただし、オクルージョンマップの作成には計算負荷がかかります。 オクルージョンマップのベイクは、レンダリング時間を短縮する効果的な方法です。

Ambient Occlusion

Ambient Occlusion マップのベイクを有効にします。 無効の場合、occlusion出力はNullレイヤとなります。

Occlusion Samples

Occlusion の計算に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Occlusion Samples を上げることでノイズを減らすことができます。

Max Distance

Occlusion の計算時で考慮される最大距離。 距離が小さいほど、オクルージョンシェーディングの計算精度は悪くなりますが、高速化されます。

Curvature

オブジェクトの丸みを測定し、その情報を曲率マップにベイクすることができます。 技術的には、このマップは、表面の凸部と凹部を保存します。 曲率マップは、摩耗したエッジや損傷のマスキングとしてよく使用されます。 曲率マップは、キャビティマップに似ていますが、キャビティマップは主にディテールに特化しているのに対し、曲率マップは表面の全体的な形状を強調します。

Curvature

Curvature マップのベイクを有効にします。 無効の場合、curvature出力はNullレイヤとなります。

Curvature Samples

Curvature の計算に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Curvature Samples を上げることでノイズを減らすことができます。

Curvature Scale

凸部と凹部の応答差を増幅させることで、曲率の全体的な強度またはコントラストを制御します。

Max Distance

小さい値(より短い距離を生成)は、凹部を強調します。 大きい値(より長い距離を表す)は、より多くの曲率を露呈し、凸部を目立たせます。

Bias

マップがより凹に見えるか、より凸に見えるかを制御します。 小さい値は凹部を強調し、大きい値は凸部を強調します。

Edge

このマップタイプは、摩耗したエッジを作成したり、オブジェクトのエッジに色を付けてその形状を強調するためのマスクとしてよく使用されます。 オブジェクトの凸ポリゴン、凹ポリゴン、または、両方のどちらからエッジを計算したいのか選択してください。

Edge

Edge マップのベイクを有効にします。 無効の場合、edge出力はNullレイヤとなります。

Edge Samples

Edge の計算時に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Edge Samples を上げることでノイズを減らすことができます。

Mode

平滑化するエッジのタイプ(凹または凸)。

Radius

丸めるエッジの半径。

Cusp Angle

この閾値未満の角度を持つポリゴンは滑らかなサーフェスと見なされ、 Edge マップには表示されません。

Cavity

キャビティマップは、オクルージョンマップに似ていますが、より多くのディテールを網羅します。 有機組織と組み合わせて使用することで、例えば、毛穴やその他の高周波数な構造を強調することができます。 オクルージョンマップとは異なり、キャビティマップでは、近接メッシュ部分間の相互作用は発生しません。

Cavity

Cavity マップのベイクを有効にします。 無効の場合、cavity出力はNullレイヤとなります。

Cavity Samples

Cavity の計算に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Cavity Samples を上げることでノイズを減らすことができます。

Max Distance

光線が近接ジオメトリを検出できる距離を制限します。 値が小さいほど(距離が短いほど)、凹部が強調されます。

Bias

完全なキャビティコントラスト(0)とフラットな結果(1)の間をブレンドします。

Thickness

厚みマップを使用すると、背面から照らされた光が表面を通過する様子を再現することができます。 光は、物体内部に一定深度まで浸透して、その後に拡散散乱されます。 良い例としては、ロウソクの蝋や皮膚が挙げられます。 この効果は、サブサーフェススキャタリングに似ています。 このマップは、厚い領域と薄い領域をグレースケールで表現します。

Thickness

Thickness マップのベイクを有効にします。 無効の場合、thickness出力はNullレイヤとなります。

Thickness Samples

Thickness の計算に使用される間接光線のサンプル数。 その結果のAOVにノイズが生じる場合は、 Thickness Samples を上げることでノイズを減らすことができます。

Invert Thickness Map

Thickness マップを反転させます。

これによって、薄い領域は暗い値を、厚い領域は明るい値を生成します。

Height

高さマップは、低解像度メッシュと高解像度メッシュ間の変位を計算したマップを生成します。

Height

Height マップのベイクを有効にします。 無効の場合、height出力はNullレイヤとなります。

Height Space

高さマップは、低解像度と高解像度の間の真の変位をベイクします。 この距離は非常に小さいので、出力画像はほぼ完全に黒く見える可能性があります。 これでは、マスキングやシェーダで役に立たないため、後で手動で再マッピングが必要になります。 高さマップを再マッピングするには、これをCustomに設定します。

True Displacement

真の変位値。 これは、視覚的に好ましくない結果となる可能性があり、低解像度と高解像度のジオメトリ的な差異が小さい場合、 ベイクされたメッシュが完全に黒く見えることがあります。

Custom

高さレイヤを Inner DistanceOuter Distance のパラメータに応じて再マッピングします。

Inner Distance

高さマップ内のデータを、内側距離から0.0の範囲に再マッピングします。

Outer Distance

高さマップ内のデータを、外側距離から1.0の範囲に再マッピングします。

Alpha

アルファマップは、表面構造を持たないオブジェクトの領域を表現します。 黒の領域は、あらゆる光線に対して不可視と扱われ、白の領域は完全に不透明です。 マップのグレースケールは、半不透明(または半透過)を表現します。

Alpha

Alpha マップのベイクを有効にします。 無効の場合、alpha出力はNullレイヤとなります。

高解像度メッシュのマスク処理

高解像度メッシュ上の有効なヒットをチェックして、低解像度UVマップではなく、これに基づいてアルファマスクを生成します。

Custom Attributes

Quick Setups

ベイクするジオメトリアトリビュートを追加します。

Attribute Name

Positionマップのベイクを有効にします。 これによって、ワールド座標値がレイヤのRGBコンポーネントにベイクされます。 無効時は、position出力はNullレイヤとなります。

Attribute Name

ラスター化するアトリビュートの名前。 これは、ジオメトリ上に存在するアトリビュートの名前に合わせてください。 ここには、Point、Vertex、Primitiveのどれかのアトリビュート名を指定することができます。

Type

ラスター化されるアトリビュートの出力タイプ。 ラスター化するには、アトリビュートが整数型、または、4コンポーネント以下の浮動小数点型である必要があります。

Mono

単一浮動小数点アトリビュート用のMonoレイヤ。

UV

float2アトリビュート用のUVレイヤ。

RGB

float3アトリビュート用のRGBレイヤ。

RGBA

float4アトリビュート用のRGBAレイヤ。

ID

整数アトリビュート用のIDレイヤ。

入力

size_ref

出力画像のサイズを決定し、メタデータを制御する標本レイヤ。

low

光線を出射し、最終的なテクスチャマップが投影されるメッシュ。 ポリゴンは、メッシュのUV座標に基づいてラスター化されます。

high

ベイクするメッシュ。

cage

オプションのカスタムケージジオメトリ。 Tracing ModeCage Meshの場合、光線は、低解像度メッシュではなくこのメッシュの法線から出射されます。

skew

歪み補正を適用する位置を示した入力マップ。

出力

normal

高解像度メッシュの接線空間法線マップ。

edgenormal

高解像度メッシュのラウンドエッジ接線空間法線マップ。

worldnormal

高解像度メッシュのワールド空間法線マップ。

position

レイヤのRGBコンポーネントに呼応したワールド空間座標値マップ。

occlusion

高解像度メッシュからの間接照明と影の効果のマップ。

curvature

高解像度メッシュの凹凸マップ。 凹ディテールは明るく、凸ディテールは暗く表現されます。

edge

高解像度メッシュのエッジディテールのマップ。

cavity

高解像度メッシュの凹ディテールのマップ。

thickness

高解像度メッシュの厚みに基づいたマップ。 厚い領域は暗い値を、薄い領域は明るい値を生成します。

height

低解像度メッシュと高解像度メッシュ間の変位マップ。

alpha

ジオメトリが存在する箇所を白、存在しない箇所を黒で出力したマップ。

custom

カスタムアトリビュートのケーブル

See also

Copernicusノード

  • Auto Stereogram

    3D錯覚を与える画像を生成します。

  • Bake Geometry Textures

    低解像度メッシュと高解像度メッシュ間のベイク処理をインタラクティブな速度で実行してテクスチャを生成します。

  • Bend

    ハンドルまたはキャプチャ領域を使用して、画像を曲げます。

  • Blend

    2つのレイヤをブレンドします。

  • Block Begin

    ブロックの開始で、入力を格納します。

  • Block End

    ブロックの終了で、出力を宣言します。

  • Block to Geometry

    ブロックをコンパイルし、そのジオメトリ表現を生成します。

  • Blur

    レイヤにブラーを適用します。

  • Bokeh

    絞り形状で各ピクセルの色を広げることでBokeh効果を生成します。

  • Bounding Rectangle

    マスクから境界矩形を求めます。

  • Bright

    レイヤを明るくします。

  • Bubble Noise

    泡ノイズを生成します。

  • Cable Filter

    ケーブルから空っぽのワイヤーを除去します。

  • Cable Merge

    2本のケーブルを1本のケーブルに結合します。

  • Cable Pack

    入力レイヤをケーブルに結合します。

  • Cable Rename

    フィルタに基づいてケーブルのワイヤーの名前を変更します。

  • Cable Sort

    ケーブルのワイヤーを名前順に並べ替えます。

  • Cable Split

    フィルタリングパラメータに基づいて、ケーブルを分割します。

  • Cable Switch

    入力ケーブルを選択します。

  • Cable Unpack

    ケーブルから個々のワイヤーを抽出します。

  • Cache

    入力レイヤをキャッシュ化して、再生速度を向上させます。

  • Camera Import

    カメラの空間内にレイヤを作成します。

  • Camera Properties

    レイヤのカメラプロパティを調整します。

  • Channel Extract

    レイヤからチャンネルを抽出します。

  • Channel Join

    複数のMonoレイヤを1枚のマルチチャンネルレイヤに結合します。

  • Channel Split

    レイヤのチャンネルをMonoレイヤに分割します。

  • Channel Swap

    マルチチャンネルレイヤ内のチャンネルを入れ替えます。

  • Checkerboard

    交互に並んだチェック柄を生成します。

  • Chladni Cymatic Patterns

    様々な振動モードを表現した干渉パターンを生成します。

  • Chroma Key

    色相、彩度、輝度の範囲に基づいて入力をキーイング(抜き出し)します。

  • Chromatic Aberration

    色収差を画像に追加します。

  • Clamp

    入力レイヤをクランプ(制限)します。

  • Cloud Noise 3D

    もくもく雲(Billowy Cloud)のようなノイズを生成します。

  • Color Correct

    画像のカラーを調整します。

  • Combine Layers

    すべての入力レイヤを合成します。

  • Combine Normals

    2つの法線マップをブレンドします。

  • Compare

    2枚のレイヤを比較してマスクを生成します。

  • Constant

    ピクセルを定数値に初期化します。

  • Contact Sheet

    入力レイヤをコンタクトシートに並べます。

  • Contrast

    コントラストをレイヤに適用します。

  • Convert Depth

    Depthレイヤを高さ、深度、距離に変換します。

  • Convert Normal

    法線レイヤを符号付き法線やオフセット法線に変換します。

  • Convolve 3×3

    レイヤを3×3カーネルで畳み込みます。

  • Copy and Transform

    スタンプをコピーし、そのコピーされたスタンプにトランスフォームを適用します。

  • Corner Pin

    参照レイヤを基準にレイヤのコーナーをピン留めします。

  • Crop

    レイヤを新しいサイズにクロップします。

  • Cross Product

    2枚のRGBレイヤに対して外積を実行します。

  • Cryptomatte

    Cryptomatteレイヤからマットを構築します。

  • Cryptomatte Decode

    CyrptomatteからカバレッジとIDをアンパックします。

  • Cryptomatte Encode

    カバレッジとオブジェクトハッシュをCryptomatteレイヤにパックします。

  • Crystal Noise

    鋭く角張ったWorleyノイズタイプを生成します。

  • Crystal Noise 3D

    3D位置から、鋭く角張ったWorleyノイズタイプを生成します。

  • Curvature

    入力レイヤの曲率を計算します。

  • Curve 3D

    2Dのイラストソフトと同様のツールを使用して、Bezierカーブ、ポリライン、NURBSカーブまでもインタラクティブに描画することができます。

  • Defocus

    入力レイヤをピンぼけさせます。

  • Denoise AI

    入力レイヤのノイズを除去します。

  • Denoise TVD

    画像からホワイトノイズを除去します。

  • Derivative

    X軸とY軸に沿ってソースレイヤの微分を計算します。

  • Dilate Erode

    レイヤを膨張または収縮させます。

  • Distort

    入力レイヤを歪ませます。

  • Dot Product

    2つのレイヤの内積を実行します。

  • Edge Detect

    入力画像内のエッジを検出します。

  • Edge Detect by Contour

    幅の異なるシルエットラインを検出します。

  • Edge Detect by Depth

    幅の異なる自己遮蔽シルエットを検出します。

  • Edge Detect by Normal

    幅の異なる折り目ラインを検出します。

  • Eikonal

    アイコナール方程式を解いて距離を計算します。

  • Equalize

    色の範囲を伸縮させたりずらすことで、色を均一化します。

  • Error

    メッセージ、警告、エラーを生成します。

  • Extrapolate Boundaries

    空っぽでない領域のエッジの色を使用して、画像の空っぽの領域を塗りつぶします。

  • Feather

    コントラストの急な変化を滑らかにします。

  • Fetch

    COPノードの出力を現在のネットワークに取り込みます。

  • File

    ディスクから画像または動画を読み込みます。

  • Fill

    レイヤを定数値で塗りつぶします。

  • Fill Connected

    レイヤの繋がった領域を塗り潰します。

  • Flip

    レイヤを水平、垂直、対角線に反転させます。

  • Flow Block Begin

    Flowシミュレーションブロックの開始。

  • Flow Block End

    Flowシミュレーションブロックの終了。

  • Flow Project Non-Divergent Multigrid

    2次元ベクトルフィールドから発散成分を除去します。

  • Font

    Type 1、TrueType、OpenTypeのフォントのテキストをレイヤ上にラスター化します。

  • Fractal Noise

    フラクタルノイズを生成します。

  • Fractal Noise 3D

    3D位置からフラクタルノイズを生成します。

  • Function

    数学関数をレイヤに適用します。

  • Gamma

    ガンマ補正をレイヤに適用します。

  • Geometry to Layer

    ボリュームをレイヤに変換します。

  • Glow

    輝度に基づいてグローを画像に追加します。

  • Grunge Aurora

    オーロラのような表示パターンを生成します。

  • Grunge Birch Bark

    樺の樹皮を模した模様を生成します。

  • Grunge Layered Noise

    単純なノイズをレイヤとして重ねることで、よりハイレベルなノイズパターンを生成します。

  • Grunge Pine Bark

    松の樹皮を模した模様を生成します。

  • Grunge Rust

    表面に錆びのような模様を生成します。

  • HSV Adjust

    カラーをRGB空間またはHSV空間に変換したり、HSVを修正します。

  • Heat Distort

    入力レイヤを歪ませて、炎周辺の熱気やその他の蜃気楼効果を模倣します。

  • Heat Distort by Layer

    入力レイヤを別のレイヤを使用して歪ませ、炎周辺の熱気やその他の蜃気楼効果を模倣します。

  • Height to Ambient Occlusion

    各ピクセルを球体と見立て、その球体が隣接ピクセルのHeight値によってどの程度オクルード(遮蔽)されているかを求めます。

  • Height to Normal

    Heightレイヤを法線レイヤに変換します。

  • Height to Shadow

    仮想光源を使用して影を生成します。

  • HeightField Visualize

    レイヤを色付けされたHeight Fieldで可視化します。

  • Hex Tile

    テクスチャをランダムにタイル化します。

  • Histogram

    レイヤからヒストグラムを構築します。

  • Hyperbolic Tile

    テクスチャパターン用の双曲正多角形タイルを生成します。

  • ID to Mask

    フィルタリングパラメータに基づいて、IDレイヤからマスクを生成します。

  • ID to Mono

    IDレイヤをMonoレイヤに変換します。

  • ID to RGB

    IDレイヤをRGBレイヤに変換します。

  • ID to SDF

    ID値が変わるまでの距離から符号付き距離フィールドを計算します。

  • Illegal Pixel

    画像内の不正なピクセルを検出し、それを修復またはハイライトします。

  • Input

    サブネットワークの入力を取得します。

  • Integrate Volume

    カメラ光線に沿ってVDBを積分します。

  • Invert

    レイヤを反転させます。

  • Invoke Block

    このノードに接続されている入力を使用して、ブロックを実行します。

  • Invoke Geometry

    このノードに接続された入力を使用して、ジオメトリ内に保存されているプログラムを実行します。

  • Julia Fractal

    ジュリア集合を計算してフラクタルを作成します。

  • Kuwahara Filter

    絵画のようなエフェクトを生成するKuwaharaフィルタを適用します。

  • Lattice Deform

    グリッドベースの変形をレイヤに適用します。

  • Layer

    レイヤを生成します。

  • Layer Attribute Create

    レイヤ上にユーザ定義メタデータを追加または編集します。

  • Layer Attribute Delete

    レイヤからユーザ定義のメタデータを削除します。

  • Layer Properties

    レイヤの基本的なメタデータを編集します。

  • Layer from Curves

    カーブからレイヤを構築します。

  • Layer from VDB

    VDBからレイヤの値を設定します。

  • Layer to Geometry

    レイヤを2Dボリュームに変換します。

  • Layer to Points

    レイヤに基づいてポイントを生成します。

  • Layer to VDB Leaf Points

    エンベロープ(包絡境界)内に含まれるVDBの各リーフに対してポイントを生成します。

  • Lens Distort

    OpenCVの係数に基づいて、レイヤに放射状および接線方向の歪みを加えます。

  • Light

    ライト方向と法線を指定してレイヤを照明します。

  • Live Video

    ライブビデオソースから画像をキャプチャします。

  • Mask from Curves

    2Dカーブからマスクを作成します。

  • Match Camera

    参照カメラに合うようにレイヤをトランスフォームさせます。

  • Match UDIM

    レイヤのピクセルを特定のUDIMタイルに合わせて再配置します。

  • Median

    中央値フィルタを画像に適用します。

  • Mirror

    任意の数の平面に基づいて画像をミラー化します。

  • Mono

    レイヤをMonoに変換します。

  • Mono to ID

    MonoレイヤをIDレイヤに変換します。

  • Mono to RGB

    MonoレイヤをRGBレイヤに変換します。

  • Mono to RGBA

    MonoレイヤをRGBAレイヤに変換します。

  • Mono to SDF

    Monoレイヤの等高線レベルから符号付き距離フィールドを計算します。

  • Null

    入力を出力に通過させます。

  • OCIO Transform

    OCIOトランスフォームを使用して、カラー空間を変換します。

  • ONNX Inference

    ONNX機械学習モデルから推論を適用します。

  • OpenCL

    レイヤ、アトリビュート、ボリューム、VDBに対してOpenCLカーネルを実行します。

  • Output

    サブネットワークの出力を収集します。

  • Phasor Noise

    波形パターンに似たPhasor(フェーザ)ノイズを生成します。

  • Pixelate

    ピクセルのサイズを上げることで、入力レイヤをピクセル化します。

  • Polar to UV

    極座標ピクセルをデカルト座標ピクセルに変換します。

  • Position Map

    ポジションマップを生成します。

  • Position Sample

    位置によって入力テクスチャをサンプリングします。

  • Prefix Sum

    レイヤの累積和を計算します。

  • Premultiply

    RGBAレイヤを事前乗算または事前乗算解除します。

  • Preview Material

    ジオメトリにプレビューマテリアルを適用します。

  • Project on Layer

    レイヤをターゲットレイヤに投影します。

  • Pyro Activate

    PyroシミュレーションのVDBのアクティベーションを変更します。

  • Pyro Advect

    VelocityでVDBを移流させます。

  • Pyro Advect by Map

    FlowマップでVDBを移流させます。

  • Pyro Axis Force

    軸周りのフォースをVelocity VDBに適用します。

  • Pyro Block Begin

    Pyroシミュレーションブロックの開始点。

  • Pyro Block End

    Pyroシミュレーションブロックの終了。

  • Pyro Build Advection Map

    Velocity VDBからFlowマップを構築します。

  • Pyro Buoyancy

    浮力を適用します。

  • Pyro Configure

    Pyroシミュレーションの設定を行ないます。

  • Pyro Dissipate

    時間の経過と共にVDB値を消散させます。

  • Pyro Disturbance

    擾乱をVelocity VDBに適用して、停滞した空気を乱します。

  • Pyro Light Ambient

    VDBの環境照明の光フィールドを構築します。

  • Pyro Light Scatter

    VDBから内部発光の光フィールドを構築します。

  • Pyro Light from Points

    VDBのポイントライトの光フィールドを構築します。

  • Pyro Packed MipMap

    VDBのインプレースMipMapを構築します。

  • Pyro Project Non-Divergent Electro Static

    Velocity VDBから発散を除去します。

  • Pyro Source from Layer

    レイヤのエンベロープ(包絡境界)からVDBへソースを設定します。

  • Pyro Source from Points

    ポイントからVDBへソースを設定します。

  • Pyro Turbulence

    乱流をVelocity VDBに適用します。

  • Pyro Uniform Force

    均一なフォースを適用します。

  • Python Snippet

    レイヤに対してPythonスニペットを実行します。

  • Quantize

    入力データを離散ステップに量子化します。

  • RGB to RGBA

    RBGレイヤをRGBAに変換します。

  • RGB to UV

    RGBレイヤをUVレイヤとMonoレイヤに分割します。

  • RGBA to RGB

    RGBAレイヤをRGBに変換します。

  • RGBA to UV

    RGBAレイヤを2つのUVレイヤに分割します。

  • ROP Image

    COPネットワークの出力をディスクに書き出します。

  • Ramp

    線形ランプおよび放射ランプを生成します。

  • Random Mono

    ランダムな値を持つMonoレイヤを作成します。

  • Random RGB

    ランダムなカラーを持つRGBレイヤを作成します。

  • Rasterize Curves

    カーブをレイヤ上にラスター化します。

  • Rasterize Geometry

    ジオメトリをレイヤにラスタライズします。

  • Rasterize Layer

    レイヤを別のレイヤのカメラにラスタライズします。

  • Rasterize Setup

    Rasterize Geometry COP用のジオメトリを準備します。

  • Rasterize Volume

    カメラから見たボリュームをレンダリングします。

  • Ray Trace

    原点マップと方向マップに基づいて、入力メッシュに対してレイトレーシングを実行します。

  • Reaction-Diffusion Block Begin

    反応拡散シミュレーションブロックの開始。

  • Reaction-Diffusion Block End

    入力とパラメータで記述された複数の化学物質の反応と拡散を解くことで、固有なパターンを生成します。

  • Remap

    レイヤをリマップします。

  • Resample

    幅、高さ、ピクセルサイズを変更して、画像スケーリングを実行します。

  • SDF Adjust

    Mono SDFレイヤの値を修正します。

  • SDF Blend

    2つのMono SDFレイヤを組み合わせます。

  • SDF Shape

    選択した形状の2D符号付き距離フィールドを作成します。

  • SDF to Mono

    SDFフィールドをMono画像レイヤに変換します。

  • SDF to RGB

    SDFフィールドをRGBカラーレイヤに変換します。

  • SOP Import

    SOPジオメトリをCopernicusに取り込みます。

  • SOP Invoke

    入力に対してコンパイルSOPブロックを呼び出します。

  • SOP Invoke Graph

    入力に対してジオメトリSOPグラフを呼び出します。

  • Scatter Shapes

    ランダム化コントロールを使用して、入力スタンプを画像上にばら撒きます。

  • Scatter on Curves

    ランダム化コントロールを用いて、入力曲線沿いに入力スタンプをばら撒きます。

  • Segment by Connectivity

    レイヤを繋がったコンポーネントに分割します。

  • Segment by Value

    Monoレイヤを、同じような値の帯域に分割します。

  • Sequence Blend

    複数の画像入力をブレンド係数でブレンドします。

  • Sharpen

    入力レイヤを鮮明化して、エッジを強調します。

  • Slap Comp Import

    Solarisビューポートからライブレイヤをインポートします。

  • Slope Direction

    高さレイヤを方向レイヤに変換します。

  • Smooth Fill

    レイヤの領域を滑らかに塗り潰します。

  • Solve Poisson Multigrid

    幾何的マルチグリッド法(Geometric Multigrid)を用いて、矩形領域内のポアソン方程式を解きます。

  • Space Transform

    位置とUV値を別の空間へトランスフォームさせます。

  • Stamp Points

    ポイント位置からレイヤにスタンプ(入れ込み)します。

  • Stash

    コマンドでこのノードの入力をスタッシュ(貯蔵)して、それをこのノードの出力として使用します。

  • Statistics

    入力レイヤの平均値、最大値、最小値を出力します。

  • Statistics by ID

    各ID島の統計情報を計算します。

  • Streak Blur

    画像にストリーク(筋)を付けることで、モーションブラー効果を加えます。

  • Subnetwork

    COPの集合体を1つのノードに整理するために使用します。

  • Surface Dither

    UV座標に対してハーフトーンのディザリングパターンを適用します。

  • Swirl

    画像レイヤを螺旋状に捩じります。

  • Switch

    入力レイヤを選択します。

  • Switch If Wired

    接続されているものに基づいて入力を選択します。

  • Switch by Type

    入力のタイプによって出力レイヤを選択します。

  • Tile Pattern

    テクスチャパターン用の四角形タイルを生成します。

  • Tone Map

    フィルム調トーンマッピング曲線を適用して、高ダイナミックレンジの入力を表示可能な範囲に圧縮します。

  • Transform 2D

    レイヤを2Dでトランスフォームさせます。

  • Transform 3D

    レイヤを3Dでトランスフォームさせます。

  • Triplanar

    X、Y、Zテクスチャを位置レイヤに投影することでテクスチャを生成します。

  • Triplanar Hex Tile

    Triplanar Projection(三平面投影)によって、目に見える繰り返しのない継ぎ目のないテクスチャリングと法線マッピングを生成します。

  • Triplanar UV

    3つの直交投影内にUVを生成します。

  • Two Way Switch If Wired

    別の入力の接続の有無に基づいて、2つの入力からどちらかを選択します。

  • UV Map

    UVマップを生成します。

  • UV Map by ID

    それぞれの繋がったID島のUVマップを作成します。

  • UV Sample

    UVレイヤを使用して入力レイヤをサンプリングします。

  • UV Transform

    2D空間でUVレイヤの値をトランスフォームします。

  • UV to Polar

    デカルト座標ピクセルを極座標ピクセルに変換します。

  • UV to RGB

    UVレイヤとMonoレイヤを結合してRGBレイヤを作成します。

  • UV to RGBA

    2つのUVレイヤを結合してRGBAレイヤを作成します。

  • VDB Activate from Points

    ポイントクラウドに基づいてVDB上のリーフをアクティブにします。

  • VDB Leaf Points

    VDB内のアクティブリーフ毎にポイントを作成します。

  • VDB Position Map

    各ボクセルにそのボクセルの位置を格納します。

  • VDB Reshape

    他のVDBのトポロジに合うようにVDBを再構築します。

  • VDB Visualize

    複数ボリュームの可視化を作成します。

  • VDB Visualize Slice

    VDBからスライスを可視化用ジオメトリとして抽出します。

  • VDB Visualize Tree

    VDBのトポロジを可視化したジオメトリを構築します。

  • VDB Visualize Velocity

    Velocity VDBを通過するストリーマをトレースします。

  • VDB from Layer

    レイヤ内の最も近い値からVDB値を設定します。

  • Vector Transform

    3D空間でRGBレイヤの値をトランスフォームします。

  • Vector Transform 2D

    UVレイヤの値を2次元空間でトランスフォームさせます。

  • Vignette

    入力レイヤの四隅を暗くします。

  • Wipe

    2つの画像間でワイプトランジションを実行します。

  • Worley Noise

    Worleyノイズを生成します。

  • Worley Noise 3D

    3D位置からWorleyノイズを生成します。

  • Wrangle

    VEXスニペットを実行して、レイヤの値を修正します。

  • Z Composite

    2つのレイヤを深度で合成します。